[mythtv-users] System hard locks several times per day, usually when paused

Thread thread at threadbox.net
Thu Sep 9 00:21:24 EDT 2004

I managed to catch some log messages this last time it froze up. The 
only pertinant messages from mythbackend are:

error reading from: /dev/video0
read: Input/output error

While my system log reports:

Sep 9 00:07:21 [kernel] hde: dma_timer_expiry: dma status == 0x21
Sep 9 00:07:31 [kernel] hde: DMA timeout error

Does that help at all? Any suggestions?

Thread wrote:

> I have since tried using a Promise PCI IDE controller, but it hasn't 
> helped a bit. I have no exhausted all my options. Is there really 
> nothing left to do but get off this VIA chipset? (buy a new mobo)
> Here's the stuff I forgot to mention in the first post. I'm on linux 
> 2.6.8-gentoo-r3 and when it freezes up, mythbackend says:
> 2004-09-08 12:39:03 Changing from None to WatchingLiveTV
> 2004-09-08 12:40:27 Found changes in the todo list.
> 2004-09-08 12:40:27 Scheduled 1 items in 0.066297 seconds.
> error reading from: /dev/video0
> read: Input/output error
> Starting up as the master server.
> 2004-09-08 13:58:36 Channel::Open(): Can't open:
> No such file or directory
> 2004-09-08 13:58:36 Channel::Open(): Can't open:
> No such file or directory
> Couldn't find input: Television on card
> is defined, but isn't attached to a cardinput.
> Any suggestions would be very much appreciated.
> See my IVTV forum post here:
> http://www.shspvr.com/forum/viewtopic.php?p=31889
> Thread wrote:
>> Hello, everybody. I've been using mythtv for about a week now, and 
>> I'm loving it. I have been experiencing freezing that is quite 
>> unique. I'll come back after I paused it, and I can see that the 
>> buffer has stopped growing. When I unpause, it keeps playing, but 
>> without sound. Over about 20-30 seconds, my interface becomes less 
>> and less responsive... until finally my x cursor stalls up and 
>> there's nothing left to do but reboot.
>> I found http://mythtv.org/pipermail/mythtv-dev/2003-June/010379.html 
>> which is a thread post that describes freezing very similar to mine.
>> The IVTV FAQ, http://ivtv.sourceforge.net/FAQ.html#_jump21 
>> <http://ivtv.sourceforge.net/FAQ.html#_jump21>, talks about the 
>> potential VIA chipset issues. I first tried disabling an 
>> Enable/Disable option in my bios about ACPI APIC along with all other 
>> ACPI options. When that didn't work, I even tried rebuilding my 
>> kernel without any ACPI stuff in it, just to be sure. It's still 
>> freezing up, though maybe less often than it was before I disabled 
>> the APIC stuff in the bios. I find it quite interesting that it only 
>> seems to happen when I have it paused, and the buffer is filling up.
>> I'm stuck at this point. Any suggestions?
>> Stuff I Have:
>> A7V880 Motherboard 
>> (http://www.pantherproducts.co.uk/Product%20Reviews/Asus%20A7V880.shtml)
>> Hauppauge PVR-250
>> ivtv-0.1.10-pre2-ck107x with the provided patch applied to mythtv
>> mythtv-0.15.1
>> ------------------------------------------------------------------------
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list