[mythtv-users] Just about there with Actisys IR200 and DigitalCable

Shawn Asmussen asmussen at cox.net
Tue Sep 7 17:30:55 EDT 2004

> Hi All...
> I am on the verge of pulling out the rest of my hair with this silly
> QDateTime issue. I have no problems running the channel_change script from
> the terminal window, but still no go from within Myth. Any of the legions
> before me who have the IR working with Myth have ANY trouble along these
> lines? Or at least somewhere a guy can look to troubleshoot? Environment
> variables? Planet alignment? You name it - I'll look... Thanks a bunch!!
> Cheers!
> Cory

I see you're using channel_change.csh (from the Howto?) for your channel
change script. Have you tried just using the change-channel-lirc.pl script
from the contrib directory in mythtv-0.15.1? I think it's pretty close to
the perl script from the FAQ, but you don't actually need to use the
c-shell script as a wrapper. I'm not sure why it is setup that way in the
FAQ. Maybe it needed to be done that way at some point in the past, but it
doesn't need to be run that way at this point. Just checking, but when you
successfully run it from a terminal window, you are doing it as the same
user that the mythbackend runs as, right?

As a diagnostic, you could try replacing the channel_change script with a
script that logs how it was called to make sure that mythtv is calling the
script correctly. Something like this should work:

echo $0 $* >> /tmp/troubleshoot.log
env >> /tmp/troubleshoot.log

Then you could try to change channels a couple of times, and see what the
log file looks like. After that you can see how the script is being
called, and also compare the environmental variables to how they look when
you're running from a terminal window to see if there might be any
differences that could be affecting it.

Shawn Asmussen

More information about the mythtv-users mailing list