[mythtv-users] Re: Does MythTV Obviate a DVD Player?

Hamish Moffatt hamish at cloud.net.au
Sat Sep 4 20:22:37 EDT 2004

On Sat, Sep 04, 2004 at 07:00:26AM -0700, Chris Vargas wrote:
> > Not really - S/PDIF output of AC3 (Dolby Digital) 
> > from nForce2 isn't working in ALSA currently. PCM
> and 
> > DTS work, but that means you can't hear the sound 
> > from most DVDs.
> Are you talking about a particular version of ALSA not
> working? Because my S/PDIF output is working just fine
> with my nForce2 Shuttle system, using ALSA 1.0.5rc1,
> and that's with AC3 and xine and my Yamaha receiver,
> as well as MythTV. (I can't get xine to play back MP2,
> but I think that's my problem with my xine
> configuration.)

Well, I'd sure like to know about your configuration. I have a Gigabyte
7N400Pro2 with nForce2 (specifically with the Soundstorm Dolby Digital
encoder etc) and it isn't working. The receiver detects AC3 but there's 
no sound.

lspci says for me:

0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio
Controler (MCP) (rev a1)
        Subsystem: Giga-byte Technology: Unknown device a002
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 5
        I/O ports at d400 [size=256]
        I/O ports at d800 [size=128]
        Memory at dd000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <available only to root>

Does yours differ?

Hamish Moffatt VK3SB <hamish at debian.org> <hamish at cloud.net.au>

More information about the mythtv-users mailing list