[mythtv-users] v4l2 not registered, saa7127 not found (Pundit/PVR-350/FC2)

Michael Cohn mythtv at calibreassociates.com
Wed Sep 1 18:05:19 EDT 2004

I've been following Jarod's guide to install MythTV on a Pundit Box w/ a PVR-350
running FC2.  I'd prefer to use the PVR's TV-Out vs. the Pundit TV-Out.  I've
run into two problems.  First, when I run:

  # /bin/dmesg |grep ivtv

I get the following output [snipped]:

  ivtv: Autodetected WinTV PVR 350 card
  ivtv: Found an iTVC15 based chip
  saa7115: starting probe for adapter ivtv i2c driver #0 (0x10005)
  tuner: chip found at addr 0xc2 i2c-bus ivtv i2c driver #0
  ivtv: Encoder revision: 0x02040011
  ivtv: Decoder revision: 0x02020023

The output is incomplete.  I don't get the expected output from "tuner:" or from
"ivtv:" as illustrated in Jarod's guide.

I continued with the install anyway to try to determine where the problem is. 
In testing the TV-Out connection I did the following:

  # /sbin/rmmod saa7127
  # /sbin/insmod saa7127 enable_output=1 output_select=1 test_image=1

Which resulted in:

  insmod: can't read 'saa7127': No such file or directory

I continued the install a few steps further to see if the problem would manifest
again.  So, after running:

  # /usr/bin/ivtvctl -u 0x3000
  # /usr/bin/ivtvctl -p 4
  # /usr/bin/ivtvctl -f width=720,height=480
  # /usr/bin/ivtvctl -v input=3,output=1

I captured video, and tried to play it with mplayer.  Mplayer produced:

  No vidix driver name provided, probing available ones 
  (-v option for details)!  vo: X11 running at 1024x768 
  with depth 24 and 32 bpp (":0" => local display) Disabling DPMS
  MPlayer interrupted by signal 11 in module: preinit_libvo

I don't know enough about the inner-workings of Myth to know if these are all
related to one another, but I would assume the problem begins with v4l2 not
getting registered.  

 - ASUS Pundit w/ PVR-350
 - Fedora Core 2 [fresh install]
 - atrpms-kickstart-23-1.rhfc2.at.i386.rpm
 - kernel: 2.6.7-1.456_4
 - sis_drv.o_4.3.0_gcc3_current.tar.gz
 - kernel-module-ivtv-2.6.7-1.456_4.rhfc2.at-0.1.10-41_pre2_ck104f.rhfc2.at.i686.rpm
 - ivtv-0.1.10-41_pre2_ck104f.rhfc2.at.i386.rpm

[/etc/X11/xorg.conf] snipped
  Section "Module"
        Load  "v4l"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
  Section "Device"
        Identifier  "Videocard0"
        Driver      "sis"
        VendorName  "Silicon Integrated Systems"
        BoardName   "SiS 630"
        Option      "XvOnCRT2" "true"
        Option      "ForceCRT2Type" "SVIDEO"
        Option      "CHTVOverscan" "true"
        VideoRam    65536

  # ivtv modules setup
  alias char-major-81 videodev
  alias char-major-81-0 ivtv
  options ivtv ivtv_debug=1 mpg_buffers=90
  options saa7127 enable_output=1 output_select=1 test_image=1
  options tuner type=2 # NTSC tuner
  options msp3400 once=1 simple=1
  add below ivtv msp3400 saa7115 saa7127 tuner
  add above ivtv ivtv-fb

Thank you in advance!

-- Michael
mythtv <at> calibreassociates.com

More information about the mythtv-users mailing list