[mythtv-users] External channel change bug on 0.16

Colin Bell colinb at gatewest.co.uk
Tue Oct 26 21:49:22 UTC 2004

Hi all

I use a serial devie to change channels (red eye) on a cable box. It 
all worked fine on 0.14 on Mandrake 9.2.
I have now upgraded to Mandrake 10.1 and I've pretty much got 
everything running again with Mythtv 0.16 except the external channel 
change command. If I type it into the console with a channel number 
(ie: /usr/bin/red_eye 120) it works fine, but even though its 
configured in the setup it doesn't do anything. I can see the "usage: 
device_com_port sendstring" in the logs so I know its being triggered.

I have also tried putting the command into a shell script and calling 
that instead,

echo "Changing to channel $1"
/usr/local/bin/red_eye $1

but nothing happens there either (the script works if I access it from 
the command line) plus I don't see the "Changing to channel X" being 
produced either in the logs or the console.

I can only assume this is a bug unless anyone can tell me otherwise.


More information about the mythtv-users mailing list