[mythtv-users] My successful setup, with some issues

David Levine curiouskangaroo at gmail.com
Wed Oct 20 18:14:40 UTC 2004

Hi, I'm a new user. As of last night I have MythTV working fine,
following Jarod's FC2 instructions on a new machine.  I do have a few
minor issues, which I'll get to in a minute.

Just so you know my technical level, going into this... I've been
using computers and writing software in one form or another since
about 1978, and am currently a Java developer.  That being said, I
work mostly on Windows these days and my Linux experience is limited
to some fairly basic stuff (for example, I use pico and have never set
up my own Linux installation before, never used apt, etc).  Just so
you understand my experience level - as a sort of mixed-up expert AND
novice user.

My hardware:
2x PVR-250s
Chaintech 7NIF2 (using the stock video and sound)
76020B1 Enlight Case
AMD Athlon XP 2600+ Barton (stock fan/heatsink)
WD-2000JB 200GB hard drive
2x 256MB Kingston HyperX DDR333 PC2700
An old AOpen DVD drive

Overpowered, yes, since I have the PVR-250s... but I wanted to be
ready for future expansion... and I wanted to make sure that
transcoding and commercial detection would be as fast as possible.

Eventually this will be only a backend.  I want to have two remote
frontend units.  However, during setup and testing (and until I
actually get and setup the frontends) it will also double as a

Before I get into the software stuff, I have one major hardware
issue... Each time I boot the machine, it complains about CMOS
corruption and resets to defaults.  Occassionally the message will be
that the CPU has been changed.  If I actually try to set anything in
the CMOS setup (even just the time and date), it will not reboot until
I use the jumper to reset the CMOS.  I tried replacing the battery
with no effect (symptoms are unchanged).  Because I can't successfully
change anything in CMOS without it not being able to POST, I can't
even set it not to pause on errors during startup so I have to
physically be there whenever it does reboot.  In theory, since the
machine will never be turned off once it is set up and the default
CMOS settings are fine for it, this is more of an annoyance and not a
show stopper... but does anyone have a clue as to what might be wrong?
 I would hate to have to disassemble everything and return the
motherboard at this point.

As far as the software side of things goes, I have successfully setup
Myth and it looks good.  Just a few minor "gotcha"s that people might
be interested in (in the order the steps appear in Jarod's guide).

First of all, I've been installing with "stable" packages, rather than

My first issue was that I couldn't install synaptic... apt couldn't
find the package.  I didn't bother with trying to figure it out, since
synaptic wasn't really necessary.

Then I could not get past installing the
kernel-module-nvidia-graphics6111-$MYKERNEL bit.  apt said it couldn't
find the package.  I switched to "testing", and then it got it.  I
then switched back to "stable".

I didn't bother with turning off aRts since I won't be using this
machine as a frontend anyway, when I am totally finished.

When I tried installing the MythTV suite, I found I had to go back and
do the kde-redhat "apt-get" line in Step 5 (which I had skipped) in
order to get MythTV to install properly.  However, apt reported it
could not find "kde" so I just removed it from the line and did
"apt-get install themer qt arts kdelibs kdebase gtk+ gtk2
redhat-artwork" and it worked.  MythTV then was installable.

I THOUGHT I had a tough time setting up IVTV, but it turned out
although I thought my cable was running all the way from the wall to
the PVR-250s, there was actually a break in the middle of the cable. 
D'oh!  And I discovered that after an hour of frustration.  So IVTV
really set up quite easily for me.  Doing a cat/mplayer test capture
and playback worked great for both cards.

I was able to install lirc and test it with irw with no problems.

Everything else was smooth.

However, when I tried using Myth itself, both tuners were displaying
rather poorly (it was "sputtering": very fast followed by brief
pauses, continuously).  I checked "top" and it showed my CPU as low. 
Also, I have DMA enabled on my hard drive.  What fixed the problem for
me was following instructions from Scott Mazur on the mailing list
from around a week ago when he said the recording profiles should be
set to 720x480 instead of 480x480.  Worked like a charm.  Both tuners
now look great, although PIP is not smooth (however, discussion on the
list from around two weeks ago seems to indicate this is a known
problem, so I'm happy to wait it out).

Another problem is that although I was able to use my remote with
"irw", the MythTV frontend doesn't seem to want to connect to it.  So
I've just been using the keyboard while testing.  Figuring this
problem out is my next project, although it isn't urgent since I'm
going to be using a separate frontend during normal use anyway, which
will probably use KnoppMyth (if I use a normal computer) or the XBox
frontend (if I go that way).   However, if anyone could suggest a few
steps to take to try to narrow down or diagnose the reason for this,
I'd be grateful.

I've successfully recorded shows, and I've even used MythWeb today to
record a show remotely.  (And, frankly, I love MythWeb - it's
terrific.)  Basically I'm a happy camper!  My next step is to move the
backend to under the stairs and to set up two front ends.  I'm going
to use David Shay's suggestion and set up a 802.11g network on two
WRT54G boxes using Sveasoft firmware and WDS.  I'll report back on
that when it is all set up.


More information about the mythtv-users mailing list