[mythtv-users] native lirc support fails- "connection refused"

Kevin Kuphal kuphal at dls.net
Fri Oct 15 14:04:49 UTC 2004

Dana Hata wrote:

>mythtv version: 0.16 (compiled with native lirc support)
>lirc version: lirc-0.7.0pre8
>I installed the lirc driver, and lircd is running, and if I use irw, I
>can see each button I press.
>When I run mythfrontend, the remote doesn't work.  I see this in the
>mythtv: could not connect to socket
>mythtv: Connection refused
>lirc_init failed for mythtv, see preceding messages
>I've got no idea why mythfrontend would not be able to to access lirc.
>Here's a side note- it seems myth tries to access /dev/lircd, because
>initially, the lirc driver only created a /dev/lirc0, and mythfrontend
>would throw the same error as above, except saying "file not found"
>instead of "connection refused".  After I added a symbolic link
>(/dev/lircd) to point to /dev/lirc0, I started getting my current error.
>Anyone have any idea?
Did you properly set the permissions on the LIRC devices per the 



More information about the mythtv-users mailing list