[mythtv-users] database errors during upgrade... SOLVED... now it won't play some recordings

anders smith anders at smiths.dk
Mon Oct 11 13:22:12 UTC 2004


I found the 'dbcheck.cpp' file in the sourcecode package where the database setup happens and could extract the commands to setup the missing 'recordedmarkup' table, and after again deleting the two columns in the 'recorded' table I could finally run the database updater succesfully and I now have a working Myth installation again.

One issue I have found is that often my recordings won't play and I get errors telling me that it's ' waiting for prebuffer... ' and that the 'prebuffer timed out...' when I try to play files that previously worked fine. 
The strange thing is that I can play the recording if I escape out the stalled recording and reenter it again....why is that and what can I do about it?

Otherwise it's a great improvement over my old .13 installation and I look forward to getting it into daily use.

thanks
anders



  ----- Original Message ----- 
  From: anders smith 
  To: Discussion about mythtv 
  Sent: Monday, October 11, 2004 11:17 AM
  Subject: [mythtv-users] database errors during upgrade...


  After upgrading vi apt-get and atrpms I'm now stuck because the database update balks..

  First I got this:

  ---snip---
  2004-10-09 14:41:42 Upgrading  to schema 1051
  DB error (performing database upgrade):
  Query was ALTER TABLE recorded ADD COLUMN lastmodified TIMESTAMP NOT 
  NULL:
  Driver error was [2/-1]:
  QMYSQL3: Unable to execute querry
  Database error was:
  Duplicate column name 'last modified'
  ---snip---

  I deleted the 'lastmodified' column in the database as well as the 'filesize' when it gave the same complaint and I deleted my 'recordedmarkup' table as it was corrupted, but now I can't get past it.....

  I did a mysqldump and I think it's complete, but because of the corruption of the 'recordedmarkup' table I can't be sure, so that is one reason why I haven't just dumped the whole 'mythconverg' database and started from scratch... the other is that I'm not sure of the best way to do it.

  Do I simply dump the database, import the mc.sql setup file and the reimport my mysqldump?

  Alternatively can someone tell me how to set up the mythconverg.recordedmarkup' table?

  thanks
  Anders




------------------------------------------------------------------------------


  _______________________________________________
  mythtv-users mailing list
  mythtv-users at mythtv.org
  http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20041011/6d5c2cdf/attachment.htm


More information about the mythtv-users mailing list