[mythtv-users] Lirc + Haupauge Gray Remote

Eric DeLabar mythtv at edelabar.org
Sat Oct 9 15:49:12 UTC 2004

I think this is a gentoo specific problem, maybe udev related, but I'm
not really sure, so here goes... 

What I've installed: 

kernel: 2.6.7-rc2-love2 
ivtv: ivtv-0.1.10-pre2-ck113n (from source, not ebuild) 
lirc: lirc-0.7.0_pre7 (ebuild)

What I've done: 

1. Compiled the kernel with no lirc support. 

2. Compiled and installed ivtv. 

3. Emerged lirc with hauppauge support. 

4. Copied the lircd-g.conf file from ivtv to /etc/lirc.conf 

5. Edited /etc/modules.d/ivtv to look like this: 

alias char-major-81 videodev 
alias char-major-81-0 ivtv 
alias char-major-61 lirc_i2c 

options ivtv ivtv-debug=0 
options saa7127 output_select=1 tuner=47 
options msp3400 once=1 simple=1 debug=0 
add below ivtv msp3400 saa7115 saa7127 tuner 
add above ivtv lirc_dev lirc_i2c ivtv-fb

6. Edited /etc/conf.d/lirc to look like this: 

# Options to pass to the lircd process 
LIRCD_OPTS="-d /dev/lirc0"

7. Added ivtv to my /etc/modules.autoload.d/kernel-2.6 

8. Ran the following: 

rc-update add lircd default

9. Rebooted. 

This is what I get: 

# ls -l /dev/lirc* 
crw-rw-rw-  1 root root   61, 0 Oct  6 18:33 /dev/lirc0 
srw-rw-rw-  1 root root       0 Oct  8 08:41 /dev/lircd

If I run: 

cat /dev/lirc0

I can press buttons on the remote and get feedback to the screen, so I
know that the remote, the receiver, and the driver are working. 

If I run: 

# irw

Nothing happens when I press buttons on the remote, and the following
appears in /ver/log/messages (after I stop irw): 

Oct  8 09:37:56 jukebox 0.7.0pre7[16005]: accepted new client on
Oct  8 09:38:00 jukebox 0.7.0pre7[16005]: removed client

If I run: 

# mode2

It fails with this, and nothing in /var/log/messages: 

mode2: error opening /dev/lirc 
mode2: No such file or directory

If I run: 

# irrecord test.out

It fails and I get the following error to the console: 


irrecord -  application for recording IR-codes for usage with lirc 

Copyright (C) 1998,1999 Christoph Bartelmus(lirc at bartelmus.de) 

irrecord: could not init hardware (lircd running ? --> close it, check

and the following in /var/log/messages: 

Oct  8 09:43:27 jukebox irrecord: could not get file information for
Oct  8 09:43:27 jukebox irrecord: default_init(): No such file or

Through all of this, the lirc_dev and lirc_i2c modules remain loaded,
and the lirc_dev and lircd processes continue running. 

Any thoughts? Thanks in advance.

More information about the mythtv-users mailing list