[mythtv-users] FC2 and IvyTV Problems and Questions

Steve Ellis steve.ellis at sympatico.ca
Tue Oct 5 23:33:30 UTC 2004

On Sun, 2004-26-09 at 18:17 +0200, jon e wishbone wrote:
> > >
> > > I got nuthin'. Not sure TVTime works w/a PVR-x50 at all, try mplayer instead.
> > > I can't recall if you already said the card definitely works or not. Maybe
> > > that's the root of the problem?
> > >
> > >
> > 
> > I can capture using 'cat /dev/video0 > /tmp/tmp.mpg' and then watch
> > the clip in mplayer. If I try mplayer /dev/video0, then it captures
> > about a frame and the errors out. I'm not sure that's supposed to
> > work, though. I'm tempted to put the card in my windows machine to see
> > if it really works.
> > 
> I tried some more tests today. I rebooted to make sure everything was
> 'clean.' Here's what I did:
> cat /dev/video0 > /tmp/tmp.mpg -> worked fine
> mplayer -vo xv /tmp/tmp.mpg -> plays & video shows immediately
> xine -V xv /tmp/tmp.mpg -> plays & video shows immediately
> mplayer -vo xv /dev/video0 -> plays, but sometimes video takes ~20
> seconds to appear
> xine -V xv /dev/video0 -> doesn't play ('no demuxer plugin available' error)
> I'm able to run the other commands with no problems any number of
> times. Then, I start mythfrontend (mythfrontend -v all -l
> /var/log/mythtv/mythfrontend.log). I try to watch LiveTV and get the
> same errors as before:
> 2004-09-26 16:52:04 ReadStringList timeout (quick).
> Remote encoder not responding.
> 2004-09-26 16:52:04 33      QUERY_RECORDER 1[]:[]IS_RECORDING
> QSocketDevice::writeBlock: Invalid socket
> 2004-09-26 16:52:04 Error writing stringlist
> Remote encoder not responding.
> I ^C to kill mythfrontend. If I try to 'cat /dev/video0 >
> /tmp/tmp.mpg,' it hangs for a few seconds and then gives 'cat:
> /dev/video0: Input/output error.'  I have an old video clip
> (/tmp/test_capture.mpg) that I keep around to test things. I can play
> it back in mplayer and xine.
> I don't know if this implies a problem with ivtv or what. Just thought
> I'd throw it there to see if it gives anyone a clue.
> I'm also not sure I mentioned this before, but I'm using ivtv version
> 1.10-45_pre2_ck108k.rhfc2.at.
> Jon

I have the same issue FC2, MythTV 0.16 with a PVR-250 cards. Records and
plays recordings fine. But When I try to watch LiveTV all I get is a
black screen and once I stop mythfrontend my backend is dead. I am
beginning to wonder if FC2 is the Distro to use. I followed Jarod's
guide and had everything working with a PVC-951 card prior to upgrading
to a PVR-250 (apart from the annoying dual audio playback, reason for
the upgrade).

Any ideas would be welcome...


More information about the mythtv-users mailing list