[mythtv-users] Re: AMD64/FC2 installation: mythtv-suite dependency issues

Axel Thimm Axel.Thimm at ATrpms.net
Sun Oct 3 07:20:56 EDT 2004


On Sat, Oct 02, 2004 at 11:38:20PM -0700, Brad Fuller wrote:
> I now have ivtv working on my AMD64/FC2/PVR250. I have to force the 
> tuner to 39 to see picture --- I found this out from other msgs on the 
> ivtv-devel list. I have a question out to the ivtv-devel list on what I 
> can do about this.
> 
> But, back to my problem with installing myth on an AMD64 system.
> When trying to install the mythtv-suite from ATrpms, It is unable to 
> satisfy some depenencies (see below). I assume that these particular 
> libraries don't exist in 64-bit. I don't know, maybe they do.  (note 
> that I tried bleeding and testing)
> 
> 1. So that's my first question: do these libraries exist.

mythmusic and mythphone do not build yet (as of 0.16) on 64
bits. mythmusic's goom/filters.c has i386 assembler and assumes
pointers/integers to be of the same size. mythphone depends on
festival that is not delivered for x86_64 for whatever reason.

> 2. My second question is a followup question: what would be the best way 
> to install the mythtv suite of apps for 64-bit?
> 
> I sure do appreciate your help!
> 
> brad
> 
> [root at killtivo utils]# yum install mythtv-suite
> Gathering header information file(s) from server(s)
> Server: ATrpms for Fedora Core 2 testing
> Server: Fedora Core 2 - x86_64 - Base
> Server: FreshRPMs for Fedora Core 2
> Server: Fedora Core 2 - x86_64 - Released Updates
> Finding updated packages
> Downloading needed headers
> Resolving dependencies
> ........Unable to satisfy dependencies
> Package mythmusic needs libSDL-1.2.so.0, this is not available.
> Package mythmusic needs libcdda_interface.so.0, this is not available.
> Package mythmusic needs libcdda_paranoia.so.0, this is not available.
> Package mythmusic needs libqt-mt.so.3, this is not available.
> Package mythmusic needs libvorbis.so.0, this is not available.
> Package mythmusic needs libvorbisenc.so.2, this is not available.
> Package mythmusic needs libvorbisfile.so.3, this is not available.
> Package mythphone needs libqt-mt.so.3, this is not available.
> Package mythphone needs libtermcap.so.2, this is not available.
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20041003/5f6eb8cb/attachment.pgp


More information about the mythtv-users mailing list