[mythtv-users] Severely squashed playback after upgrade to 0.15

papenfuss at juneau.me.vt.edu papenfuss at juneau.me.vt.edu
Sat May 29 12:42:27 EDT 2004

	I have a problem with a similar setup.  My video setup is a bit weird, 
as I've fried up a modeline that spits out interlaced 29.97/59.94 Hz NTSC-spec 
video.  It's an ATI Rage 128 so I can get XV with interlaced and low-frequency.  
When I run it in interlaced mode like this, it shows the top half of the screen 

	My "solution" is a temporary hack.  I tried the GATOS driver and it's 
been fixed.  I went to their site and replaced this file:
with the GATOS one.  When I updated the system some last week, it broke it 
again, but re-replacing it fixed it.

	It might be the same issue.

 On Fri, 28 May 2004, Jason E Miller wrote:

> I upgraded MythTV to 0.15 using Axel's rpms last night and
> now the picture is squashed vertically when I try to view
> live TV or watch a recorded show.  By "squashed" I mean that
> the video fills the width of the screen as it should but it
> is compressed in the vertical direction to approximately
> 1/8th of its normal size.  The result is a thin band of
> badly distorted video running across the middle of the
> screen.  It seems to be the full image compressed down (i.e.
> I don't think there is any cropping going on).  This problem
> is present with both new recordings as well as recordings
> made before the upgrade).  Both the GUI and MythVideo seem
> to work perfectly.  All of this worked perfectly pre-upgrade.
> There are no unusual messages in the logs from either the
> backend or the frontend.
> A few additional details... I'm running Redhat 9 and using
> the TV-out on an ATI video card (no PVR-350 yet).  A few
> days ago, in preparation for the upgrade, I manually upgraded
> wget and then did:
>    apt-get update && apt-get dist-upgrade
> The old 0.14 system worked fine after this but I don't
> remember if I actually restarted the frontend or backend after
> the upgrade.  I can check the logs later if it's important.
> For the MythTV upgrade last night, I did:
>   apt-get update
>   apt-get install mythtv-suite
> I doubt that this is related but I'll mention it just in case:
> I did have trouble with the mysql commands (I'm running MySQL
> 3.x) to update the channel icons.  After running the commands,
> I ran mythtvsetup and went into the channel editor and found a
> huge mess.  The path to the icon file was in the channel name
> slot, the channel ID was 32768 for every channel, etc.  I
> decided that I didn't need icons right now so I restored my
> database, reran setup and just skipped the part about moving
> channel icon info.  Now everything looks reasonable.
> Has anyone else seen a problem with playback being squashed
> like this?  Is it possible that the dist-upgrade wrecked
> some package that is needed for playback under 0.15 but not
> 0.14?
> 	-Jason

* The prime directive of Linux:  					*
* 	- learn what you don't know, 					*
* 	- teach what you do.						*
* 						(Just my 20 USm$)	*

More information about the mythtv-users mailing list