[mythtv-users] UK xmltv/tv_grab_uk_rt woes - argh!

Stephen Tait tait at digitallaw.co.uk
Tue May 4 14:46:10 EDT 2004

At 19:01 04/05/2004 +0100, you wrote:
>That's right, I'm using the S-Video input. Strangely I had trouble with the
>composite input so I had to buy an S-Video cable. No great trouble I guess
>but still would be nice if all the inputs worked. :-)

Oh well, I'll burn that bridge when I come to it. I wanted to use composite 
too, especially since the VCR doesn't have an SVid out. More confugulating 
with the ivtv module parameters I guess...! Out of interest, what's your 
module loading script for ivtv? Mines only loading the very basics at the 
moment until can figure out how to get lirc to compile.

alias char-major-81     videodev
alias char-major-81-0   ivtv
#alias char-major-61 lirc_i2c
options ivtv debug=0 mpg_buffers=30 ivtv_pal=1
options tuner type=1
options saa7127 pal=1 enable_output=1 output_select=0
add below ivtv msp3400 saa7115 saa7127 tuner
#Following line removed due to fubarred 0.7 i2c support
#add above ivtv lirc_dev lirc_i2c

> > >If you post your xmltv output (what it is that suggests to
> > you that a
> > >user/pass is needed in particular) then I might be able to help some
> > >more.
> >
> > The error message I saw spewed out of the CLI was as follows:
> >
> >  > finding channels:       could not get channels page
> >  >
> > http://www.radiotimes.com/PersonalisationServlet?event=3&chann
> > elType=1&includeUnchosenChannels=true&jspLocation=/jsp/select_
> > channels.jsp&rtError=/jsp/error.jsp&jspError=/jsp/register.jsp
> > &next_page=tv_select
> >  >
> >  > - aborting
> >
> > Now if I put my 'Know About As Much About Web Coding As Your Average
> > FrontPage Programmer' hat on, that looks like a "You must register,
> > damnit!" error - but as Adam says, his is working fine.
>Bearing in mind I know nothing about XMLTV's internals, I would say this
>looks like it is trying to retrieve a web page from the RT site, and its
>failing (but you knew that). From looking at my output I think it uses this
>channel list to compare to your xmltv ids stored in ~/.mythtv/channel or
>whatever and then start downloading listings. This might seem ridiculous as
>you're using Gentoo and no doubt have already tested your internet access
>many times, but you could confirm that this page is accessible. Maybe
>something is preventing you from getting to the RT site in the first place?

Well, I can browse the RT site just fine through Links (though only if I 
use www.radiotimes.com - using .co.uk gives me a failed host). I don't know 
if this is due to either their website/DNS being pants or (more likely) 
BTOpenWound's DNS being pants (which it is), or some more sneaky and 
hitherto unknown method employed by the RT programming elves. I didn't 
check out *every* page, but was able to view all of the channel listings. 
The fact that XMLTV seems to be getting the "login, you fool!" page 
indicates to me that something has gone wrong with accessing the page, 
especially since someone else is reporting the same problem on the XMLTV 
bug list at sourceforge.

Anyhoo, I'll give bleb a whirl (it's done in BASH, so I'm alot more 
familiar with the syntax) and see how that goes - if anyone has any sample 
configs, any examples or gotchas would prove invaluable.

>As an aside, I've never tried the bleb listings, but if you get them to work
>I'd love to know how good they are.

We live in eternal hope, I guess :^)

Thanks for the help guys!

>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list