[mythtv-users] help with mythvideo not playing anything

rosenbla at uchastings.edu rosenbla at uchastings.edu
Wed Mar 31 10:47:11 EST 2004

Mythvideo won't play anything it just says "Loading..." and the file never plays. 

My system is an EPIA-M10000(N) with gentoo and I followed the guide and used the ebuilds from the alterself.com wiki. I have 1 M179 in the box and it and ivtv work like a charm only 20% cpu usage on play back. I have tried several different command lines for mplayer including -vo xv and -vo x11 as well as trying to download the VeXP player and use that instead. I have yet to get mplayer to play anything! either mpeg2 or mpeg4. I have pasted all the out mplayer gives below, it just seems to never start playing. I know the files I am trying to play are fine, they play in my windows box and the particular file below played under mplayer when I had a mandrake setup a while back. I have also tried more than one version of mplayer from portage.

This is the mplayer output:

----Begin MPlayer Output ------
MPlayer 1.0pre3-3.3.3 (C) 2000-2003 MPlayer Team

CPU: IDT/Centaur/VIA C3 Nehemiah (Family: 6, Stepping: 5)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/share/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf: 61 audio & 169 video codecs
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /usr/share/mplayer/input.conf parsed: 53 binds
Setting up LIRC support...

Playing /var/videos/dvd/Head of State.avi.
Cache fill: 19.63% (1646592 bytes)    AVI file format detected.
VIDEO:  [XVID]  544x320  24bpp  23.976 fps  1198.5 kbps (146.3 kbyte/s)
Clip info:
 Software: transcode-0.6.10
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
GetModeLine - scrn: 0 clock: 26700
GetModeLine - hdsp: 720 hbeg: 736 hend: 808 httl: 896
              vdsp: 480 vbeg: 481 vend: 484 vttl: 497 flags: 0
vo: X11 running at 720x480 with depth 16 and 16 bpp (":0" => local display)
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 544 x 320 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.70:1 - prescaling to correct movie aspect.
VO: [x11] 544x320 => 544x320 Planar YV12  [fs] [zoom]
----End MPlayer Output ----

And it just hangs there! Still says "Loading..." on the screen 

More information about the mythtv-users mailing list