[mythtv-users] DVB-T on Epia Nehemia M10000

David Lodeiro dlodeiro at inspired.net.au
Tue Mar 2 18:43:54 EST 2004

On Tue, 2 Mar 2004 12:46 pm, Ivor Hewitt wrote:
> On Tuesday 02 March 2004 21:23, David Lodeiro wrote:
> > I've got a wierd problem occuring when it try to watch tv under myth tv (
> > the card is functioning fine, I can use dvbstream and mplayer to watch
> > it, and I have set up mythtv with this card, avermedia dvb-t, on a
> > different motherboard )
> >
> > If I select watch live tv, mythfrontend just crashes and the error on the
> > terminal where I started mythfrontend is simply
> >
> > Unknown codec: 4
> >
> > I'm pretty sure the onboard decoder is working as mplayer only uses 15 -
> > 25 % whilst watching a divx movie.
> Unless you are using a copy of mplayer you've patched yourself with via
> mpeg development code then mplayer is only using software decoding.
> > Does anyone have any ideas?
> Disable the "Use VIA HW Mpeg decoder" option in playback settings and try
> again.
Ok, I tried that, and this is the error I get now

bash-2.05b# mythfrontend
2004-03-02 23:41:22 mythfrontend version: 0.14.20040123-1 
2004-03-02 23:41:22 Enabled verbose msgs : important general
2004-03-02 23:41:23 Registering Internal as a media playback plugin.
2004-03-02 23:41:24 Registering MythMusic Media Handler as a media 
2004-03-02 23:41:28 Connecting to backend server: 
(try 1 of 5)
2004-03-02 23:41:28 Using protocol version 1
2004-03-02 23:41:28 Using protocol version 1
2004-03-02 23:41:28 Using protocol version 1
Input #0, mpeg, from 
  Stream #0.0: Video: mpeg2video, 720x576, 25.00 fps
  Stream #0.1: Audio: mp2, 48000 Hz, stereo, 256 kb/s
2004-03-02 23:41:30 Opening OSS audio device '/dev/dsp'.

       ---------------------- DirectFB v0.9.20 ---------------------
             (c) 2000-2002  convergence integrated media GmbH
             (c) 2002-2003  convergence GmbH

(*) Single Application Core. (2004-02-18 23:49)
(*) DirectFB/misc/memcpy: using linux kernel memcpy()
(*) DirectFB/InputDevice: IMPS/2 Mouse (1) 0.9 (convergence 
integrated media GmbH)
(*) DirectFB/InputDevice: IMPS/2 Mouse (2) 0.9 (convergence 
integrated media GmbH)
(*) DirectFB/InputDevice: Keyboard 0.9 (convergence integrated media 
(*) DirectFB/GraphicsDevice: Generic Software Rasterizer 0.6 
(convergence integrated media GmbH)
(*) DirectFB/Layer: Enabled 'FBDev Primary Layer'.
 (!!!)  *** CAUTION [letting unprivileged 
IDirectFBDisplayLayer::GetSurface() call pass until cooperative 
level handling is finished] *** idirectfbdisplaylayer.c (147)
(#) DirectFBError [Couldn't get our display layer - this shouldn't 
happen]: ID not found!
2004-03-02 23:41:32 Changing from None to WatchingLiveTV
[mpeg2video @ 0x8284188]get_buffer() failed (1 1073741824 2 (nil))
decoding error

This happened even if the DirectFB section was commented out in settings.pro.

For the sake of completeness, following is info of the system I am doing this 
on ( other than the allready mentioned motherboard )

Gentoo 1.4


dmesg follows, I appologise for the long post and thankyou for the response

Linux version 2.6.1-epia (root at mythtv) (gcc version 3.3.2 20031218 (Gentoo 
Linux 3.3.2-r5, propolice-3.3-7)) #8 Wed Feb 18 12:13:34 UTC 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001dff0000 (usable)
 BIOS-e820: 000000001dff0000 - 000000001dff3000 (ACPI NVS)
 BIOS-e820: 000000001dff3000 - 000000001e000000 (ACPI data)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
479MB LOWMEM available.
On node 0 totalpages: 122864
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 118768 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.2 present.
ACPI: RSDP (v000 VT9174                                    ) @ 0x000f6560
ACPI: RSDT (v001 VT9174 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1dff3000
ACPI: FADT (v001 VT9174 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x1dff3040
ACPI: DSDT (v001 VT9174 AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
Building zonelist for node : 0
Kernel command line: root/dev/hda3
Initializing CPU#0
PID hash table entries: 2048 (order 11: 16384 bytes)
Detected 999.543 MHz processor.
Using tsc for high-res timesource
Console: colour VGA+ 80x25
Memory: 481280k/491456k available (2807k kernel code, 9396k reserved, 1208k 
data, 160k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 1974.27 BogoMIPS
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
checking if image is initramfs...it isn't (ungzip failed); looks like an 
Freeing initrd memory: 99k freed
CPU:     After generic identify, caps: 0380b03d 00000000 00000000 00000000
CPU: L1 I Cache: 64K (32 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 64K (32 bytes/line)
CPU:     After all inits, caps: 0380b03d 00000000 00000000 00000000
CPU: Centaur VIA Nehemiah stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfb260, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20031002
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
SCSI subsystem initialized
drivers/usb/core/usb.c: registered new driver hub
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 
spurious 8259A interrupt: IRQ7.
NET: Registered protocol family 23
viafb: VIA CLE266 framebuffer 0.8 initializing
viafb: viafb : DE807000
viafb: framebuffer size = 32 Mb
mtrr: MTRR 4 not used
mtrr: 0xd8000000,0x2000000 overlaps existing 0xd8000000,0x800000
viafb: X:720 Y:576
viafb: mode=720  bpp=32  refresh=255  TVon=0  TVtype=2 
viafb: VQ start:1FC0000  end:1FFFFFF  size:40000
viafb: Cursor start:1FBF000  end:1FBFFFF  size:1000
viafb: mode=720  bpp=32  refresh=255  TVon=0  TVtype=2 
viafb: irq handler installed, IRQ(0x200) = 80080c00
fb0: CLE266 frame buffer device
devfs: v1.22 (20021013) Richard Gooch (rgooch at atnf.csiro.au)
devfs: boot_options: 0x1
NTFS driver 2.1.5 [Flags: R/W].
ACPI: Power Button (FF) [PWRF]
ACPI: Processor [CPU0] (supports C1 C2, 2 throttling states)
Console: switching to colour frame buffer device 90x36
pty: 256 Unix98 ptys configured
lirc_dev: IR Remote Control driver registered, at major 61 
Real Time Clock Driver v1.12
hw_random hardware driver 1.0.0 loaded
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected VIA CLE266 chipset
agpgart: Maximum main memory to use for agp memory: 409M
agpgart: AGP aperture is 128M @ 0xd0000000
[drm] Initialized via 1.1.0 20020814 on minor 0
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
via-rhine.c:v1.10-LK1.1.19-2.5  July-12-2003  Written by Donald Becker
eth0: VIA VT6102 Rhine-II at 0xe800, 00:40:63:d3:b2:a8, IRQ 10.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky
Linux video capture interface: v1.00
bttv: driver version 0.9.12 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:00:14.0, irq: 5, latency: 32, mmio: 0xde003000
bttv0: subsystem: 1461:0761 (UNKNOWN)
please mail id, board name and the correct card= insmod option to 
kraxel at bytesex.org
bttv0: using:  *** UNKNOWN/GENERIC ***  [card=0,autodetected]
bttv0: using tuner=-1
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips: 
SAA5249 driver (SAA5249 interface) for VideoText version 1.7
saa7146: register extension 'budget dvb'.
saa7146: register extension 'budget dvb /w video in'.
saa7146: register extension 'budget_ci dvb'.
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
bt878(0): Bt878 (rev 17) at 00:14.1, irq: 5, latency: 32, memory: 0xde004000
attach: checking "bt878 #0 [sw]"
find by pci: checking "bt878 #0 [sw]"
attach: "bt878 #0 [sw]", to card 0
DVB: registering new adapter (Ave).
DVB: registering frontend 0:0 (Microtune MT7072DTF)...
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
    ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:pio, hdd:DMA
hda: ST340014A, ATA DISK drive
Using anticipatory io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 1024KiB
hda: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(33)
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
Console: switching to colour frame buffer device 90x36
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: irq 5, pci mem e195e000
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:10.3: USB 2.0 enabled, EHCI 1.00, driver 2003-Jun-13
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
Initializing USB Mass Storage driver...
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Generic Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
I2O Core - (C) Copyright 1999 Red Hat Software
I2O: Event thread created as pid 11
i2o: Checking for PCI I2O controllers...
I2O configuration manager v 0.04.
  (C) Copyright 1999 Red Hat Software
I2O Block Storage OSM v0.9
   (c) Copyright 1999-2001 Red Hat Software.
i2o_block: Checking for Boot device...
i2o_block: Checking for I2O Block devices...
i2o_scsi.c: Version 0.1.2
  chain_pool: 0 bytes @ ddc44540
  (512 byte buffers X 4 can_queue X 0 i2o controllers)
i2c /dev entries driver
attach: checking "SMBus Via Pro adapter at 0500"
Advanced Linux Sound Architecture Driver Version 0.9.7 (Thu Sep 25 19:16:36 
2003 UTC).
via82xx: Assuming DXS channels with 48k fixed sample rate.
         Please try dxs_support=1 option and report if it works on your 
PCI: Setting latency timer of device 0000:00:11.5 to 64
hub 1-0:1.0: over-current change on port 5
hub 1-0:1.0: over-current change on port 6
ALSA device list:
  #0: VIA 8235 at 0xe400, irq 10
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET: Registered protocol family 1
NET: Registered protocol family 17
ACPI: (supports S0 S1 S4 S5)
RAMDISK: Couldn't find valid RAM disk image starting at 0.
request_module: failed /sbin/modprobe -- nls_iso8859-1. error = -16
Unable to load NLS charset iso8859-1
found reiserfs format "3.6" with standard journal
Reiserfs journal params: device hda3, size 8192, journal first block 18, max 
trans len 1024, max batch 900, max commit age 30, max trans age 30
reiserfs: checking transaction log (hda3) for (hda3)
Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 160k freed
Adding 506036k swap on /dev/hda2.  Priority:-1 extents:1
cle266vgaio: no version for "struct_module" found: kernel tainted.
cle266vgaio: There is already a driver installed.<6>eth0: Setting full-duplex 
based on MII #1 link partner capability of 45e1.
request_module: failed /sbin/modprobe -- snd-card-1. error = 256
nfs warning: mount version older than kernel
NFS: NFSv3 not supported.
nfs warning: mount version older than kernel
i2c_adapter i2c-0: sendbytes: error - bailout.
sp887x_initial_setup: firmware upload... done.
bttv0: IRQ lockup, cleared int mask [bits: OFLOW GPINT*]
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
Console: switching to colour frame buffer device 90x36
Console: switching to colour frame buffer device 90x36

David Lodeiro

More information about the mythtv-users mailing list