[mythtv-users] Problem recording AC3 from DVB-T

Hamish Moffatt hamish at cloud.net.au
Wed Jun 23 10:49:49 EDT 2004

On Wed, Jun 23, 2004 at 11:50:52AM +1000, Stuart Cameron wrote:
> I'm in Melbourne, Australia, running MythTV with a DVB-T card. I've been
> trying to record SD broadcasts using the AC3 PID (set up in mythtv-setup in
> the channel editor). I'm using the "scan" tool to find the correct PIDs,
> here's the dump for one channel in particular:
> I can record from the standard audio PIDs fine (eg. 0x02d0) and they play
> back great either via the offical front-end or the XBox Media Center
> frontend I'm running, but if I specify the AC3 PID (0x02d1) the mythbackend
> doesn't appear to correctly identify the audio as an AC3 stream. When a
> recording starts using the AC3 PID the backends logs this:
> As you can see, it thinks the AC3 stream is still a Layer 1 stream, just
> with a higher bit rate than usual. I'm running the released 0.50.1 build,
> I've also tried earlier CVS snapshots over the past with the same result.

Hi Stuart,

Detecting AC3 in received DVB seems a bit tricky. Have a Google for
KaxTV, which is a tool that can do it.

As to Myth misdetecting the audio as Layer 1, I'd wonder whether that
matters in practice? Does it alter the data stream, or just stream it to
disk anyway?

Hamish Moffatt VK3SB <hamish at debian.org> <hamish at cloud.net.au>

More information about the mythtv-users mailing list