[mythtv-users] second instance of lirc "could not connect to socket"

Matt Morgan matt at jiffycomp.com
Thu Jul 22 22:12:04 EDT 2004

Sorry for the length of this message, but I've done a bit of work on it 
and I'm trying to include everything I know. I'm trying to get a second 
instance of lirc running so I can use an IRBlaster to change channels on 
my cable box. I followed the instructions at


and it doesn't quite work for me. I run knoppmyth, so I posted a couple 
times on that forum, but the answers have kind of dried up over there so 
I'm trying this more general list. In case anyone's curious, those 
postings are at


but I'll paraphrase it here. Here's the short background: I have a 
WinTV-PVR250, an NVIDIA GeForce2 MX400, and everything else is working. 
I can watch TV, DVD's, play music, check the weather ... and the 
PVR250's remote works great, so my first instance of lirc is fine. I 
just can't really record without mythtv controlling the channels on the 
box. Following rwraithr's instructions, I first tried to edit 
modules.conf manually, but after being scolded for that (in the 
knoppmyth forum) I modified /etc/modutils/lirc instead to include the 
second instance. So that file looks like

path[toplevel]=/lib/modules/`uname -r`/misc
alias char-major-72 remote_sir
below remote_sir remote_dev
options remote_sir irq=3 io=0x2f8
alias char-major-61 lirc_i2c

and when I run update-modules to get it written into /etc/modules.conf, 
it runs fine. Upon rebooting everything that already worked, continued 
to work. NOTE: I have never done anything with these modules before, so 
if I did something stupid in /etc/modutils/lirc, I wouldn't know.

BUT I do know there's a problem, because when I try to run 
change_channel.sh, or channel.pl (which it calls) I get this:

/usr/local/bin/remote_irsend: could not connect to socket
/usr/local/bin/remote_irsend: Permission denied

searching for this "could not connect to socket error" on the archives 
of this mailing list looked promising at first; but the most direct 
advice I could find, that I chmod 666 /dev/lircd (or in my case, 
actually chmod 666 /dev/remoted), didn't help. Same error. And some 
other tips (might be a problem with attaching to the X server if some 
other user is running lirc) don't make sense for me, I don't think. A 
few of them, like


mention conflicts with pre-existing versions of lircd, and solutions 
involving getting rid of the older versions; but I checked and I have 
only one version of remote-anything, including remoted.

I guess the one confusing bit is, I can't find any postings that mention 
this problem in reference to a second instance of lirc, the way it's 
done according to rwraithr's excellent instructions. Everybody else gets 
the error with plain-old lirc, and that was not a problem for me.

Any suggestions?



More information about the mythtv-users mailing list