[mythtv-users] Jittery, jerky, stuttering video (yes, again)

Roger.Little at mchsi.com Roger.Little at mchsi.com
Tue Jul 20 12:06:43 EDT 2004

I absolutely love MythTV (and KnoppMyth) but have 1 issue that is really
bothering me.  During MythTV playback (and mplayer playback of Myth (or SageTV)
material) I have jitter problems like what has been described before.  DVD
playback works perfect in Xine and MPlayer with no jitter.  Here are my system

KnoppMyth R4V4.1
Asus A7N8X-E Deluxe Nforce2 motherboard with MCP-T
AMD 2600+ Barton
512MB PC3200
120GB 7200 RPM drive (with dma enabled)
Hauppauge PVR-250
GeForce FX5200 128MB (latest drivers, 6106)
Infocus X1 DLP projector at 800x600

I have tried using all combinations of the following options and nothing helps:

Deinterlace playback
Jitter reduction
Experimental AV sync
xvMC Decoding

If I change the refresh rate from 60.32 Hz to 59.94 Hz the jitter is very
different, but still very annoying.  Here is an example, where "-" is normal
playback and "+" is stuttering playback:
60.3 Hz ->    --+--+--+--+--+--+
59.94 Hz ->  ---------++++++++++-----------+++++++

I have the same problem on Windows with SageTV and BeyondTV but can make the
problem go away by enabling DXVA (Direct-X video acceleration) and HWMC
(Hardware Motion Compensation) in the mpeg decoder.  But Myth blows away SageTV
and BeyondTV by far and is what I want to use if possible.

I have read through all posts on this list and on the KnoppMyth message board
and have tried all suggestions that I could find.  What else can I try?  Maybe
downgrade the video drivers?  Maybe the jitter reduction and Experimental AV
sync doesn't work with the latest NVidia drivers?  Or could it be NForce2
sound-related?  Any help will be greatly appreciated.

More information about the mythtv-users mailing list