[mythtv-users] KWorld Card/Gentoo

David Peach mailinglists at dpeach.com
Fri Jan 23 01:40:30 EST 2004

Gentoo 1.4
MythTV 0.13
Kernel 2.4.22

KWorld BT878 Based TV Tuner card (KW-TV878RF-PRO)
Radeon 32MB (not sure which one but lspci give me this: "VGA compatible
controller: ATI Technologies Inc Radeon R100 QD [Radeon 7200]")

Let me say that I have tried lots of things over the last 12 hours. Don't
assume though that I have done anything intelligent. I may have modified
config files and don't remember (though I have tried to document in the
file if I changed something) what it was and what I changed it to.

My first knowledge that the card is not working correctly is when I do:
mythsetup. I get into the Capture Cards config area and select: Standard
V4L Caputre Card. I choose /dev/video0 (though I have tried both of the
options). I also choose /dev/vbi0 (though I have no idea what that is).

I then set up my video source.

When I go into Input Connections there is nothing there. The terminal is
saying: Couldn't open /dev/video0 to probe its inputs.

I have tried running xawtv to get information and I end up with:
This is xawtv-3.86, running on Linux/i686 (2.4.22-gentoo-r5)
WARNING: Your X-Server has no DGA support.
WARNING: couldn't find framebuffer base address, try manual
         configuration ("v4l-conf -a <addr>")
v4l2: open /dev/v4l/video0: Permission denied
v4l2: open /dev/v4l/video0: Permission denied
v4l: open /dev/v4l/video0: Permission denied
no video grabber device available

I have commented out this line:
# Option    "omit xfree86-dga"
I have added the line (as per another post I saw):
Option "xfree86-dga"

lsmod returns:
Module                  Size  Used by    Not tainted
bttv                   93504   0
i2c-algo-bit            7080   0  [bttv]
i2c-core               13476   0  [bttv i2c-algo-bit]
floppy                 47836   0  (autoclean)
snd-pcm-oss            34372   0
snd-mixer-oss          10864   1  [snd-pcm-oss]
snd-via82xx            10720   1  (autoclean)
snd-pcm                54016   0  (autoclean) [snd-pcm-oss snd-via82xx]
snd-ac97-codec         35512   0  (autoclean) [snd-via82xx]
snd-mpu401-uart         2752   0  (autoclean) [snd-via82xx]
snd-rawmidi            12192   0  (autoclean) [snd-mpu401-uart]
snd-page-alloc          5428   0  (autoclean) [snd-via82xx snd-pcm]
snd-seq-oss            22016   0  (unused)
snd-seq-midi-event      3264   0  [snd-seq-oss]
snd-seq                33584   2  [snd-seq-oss snd-seq-midi-event]
snd-timer              13156   0  [snd-pcm snd-seq]
snd-seq-device          3568   0  [snd-rawmidi snd-seq-oss snd-seq]
snd                    28356   0  [snd-pcm-oss snd-mixer-oss snd-via82xx
snd-pcm snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-oss
snd-seq-midi-event snd-seq snd-timer snd-seq-device]
soundcore               3364   6  [bttv snd]
usbcore                55488   1
3c59x                  25520   1

I have enabled the i2c sections of the kernel. I have not patched anything
in my kernel.

I am not trying to use lirc at the moment.

This card just worked in Mandrake 9.2. But the video was very poor and
slow. Any attempt to help the problem in Mandrake did not yeild acceptable
results. Since I wanted to make this a dedicated box, I decided to try it
with Gentoo. Where Mandrake adds a lot of bulk and bloat to a
configuration, it at least made me not have to think.

Let me know what other information is needed.

I appreciate you taking the time to help. Maybe I will have my wife's
Christmas present ready for next year. :-)


More information about the mythtv-users mailing list