[mythtv-users] Cant load ivtv

Scott Francis scott.francis at newisys.com
Tue Jan 20 09:39:49 EST 2004

If you reread the ivtv wiki instructions they tell you to edit the Makefiles/header files and remove custom from them prior to building.  The issue you have is that the drivers don't match your kernel.


-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org]On Behalf Of John Barton
Sent: Monday, January 19, 2004 10:03 PM
To: 'Discussion about mythtv'
Subject: RE: [mythtv-users] Cant load ivtv

1.  I believe it is /lib/modules/linux-2.4.22-21mdk/

2. 2.4.22-21mdk

3. 2.4.22-21mdkcustom

4. /usr/src/linux-2.4.22-21mdk/drivers/media/video/ivtv.o

I had originally compiled it with the -26 kernel because
that is what urmpi brought down when I asked it for the
kernel-source, but I got -21 because that is what my
kernel is(it is slightly modified, only to enable remote
control support, it comes in as non-standard keyboard
input, so I think only keyboard.h was modified).

I've stopped 6,952 spam messages. You can too!
One month FREE spam protection at http://www.cloudmark.com/spamnetsig/

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Ray Olszewski
Sent: Monday, January 19, 2004 7:28 PM
To: mythtv-users at mythtv.org
Subject: RE: [mythtv-users] Cant load ivtv

At 05:50 PM 1/19/2004 -0800, John Barton wrote:
>I tried again with the other kernel source(2.4.22-21)
>and I am getting the same result.  Here is what I did:
>cd ivtv/driver
>make clean
>cd ../utils
>make clean
>cd ../driver
>cd ../utils
>cp test_ioctl /usr/local/bin
>cd ../driver
>make install
>cd ../utils
>make install
>(I had already edited /etc/modules.conf from previous
>attempts, so I left it alone, although I did double-check
>that everything was right)
>depmod -a
>modprobe ivtv
>modprobe: Can't locate module ivtv
>I did have to change the KERNELDIR in the makefile, because
>the source was not in fact in /lib wherever, but in
>/usr/src/linux-2.4.22-21mdk/ . I changed this in both
>makefiles(driver and utils).  I hope I was less vague about
>it this time.

If you changed it to "/usr/src/linux-2.4.22-21mdk/", you should be OK on

this score. The path is contains is *supposed* to be a symlink to the 
actual location of kernel source (probably created by "make 
modules_install" in the kernel Makefile, but that's really just a

This sounds more and more like a naming problem. (In saying that, I'm 
assuming that all of the commands listed above reported no problems --
errors or warnings -- except for the final modprobe error. I'm also 
assuming you were root when you did all of it.)

1. What is the actual name of the directory path to your modules for

2. Alternately, what is the name of the running kernel ("uname -a")?

3. What is the name of the kernel in your kernel-source file (this gets 
constructed from the 4 kernel-name variables near the top of the kernel 

If the answers to 2 and 3 don't contain the same name, then that is your

problem. If they do, then ...

4. What does "find / -name ivtv.o" (run as root) return in the way of 
locations for copies of the module? If your procedure is not putting the

module in the right place, where *is* it putting ivtv.o?

More information about the mythtv-users mailing list