[mythtv-users] Myth only recording one show

Kyle Kelly kyle at kylekelly.com
Mon Jan 5 20:00:29 EST 2004

Axium Computer Services wrote:

> Kyle Kelly wrote:
>> Sabin Dang wrote:
>>> Hello all, I've got a strange problem that I've been wrestling with 
>>> for some time. I'm hoping that someone out there has had a similar 
>>> problem and has found a solution.
>>> My myth setup will record one show, and after that I am unable to 
>>> record anymore shows or watch tv (I get the "All available inputs 
>>> are being used message").  I've checked the myth status page and it 
>>> reports that it is not recording.  Also at this stage if I go into 
>>> watch recordings and attempt to delete a recording, mythfrontend 
>>> will pause for a length of time and then report that it cannot 
>>> connect with the backend.
>>> I've verified that the backend is still running, and all other 
>>> components of myth work fine (video, watching recordings, etc).
>>> Doing an lsmod I notice that ivtv is reported as being used by a 
>>> process (keventd), attempting to do an rmmod ivtv results in "ivtv: 
>>> Device or resource busy." Killing mythbackend and restarting it 
>>> solves all my problems.
>>> At this point I've got a cron job restarting mythbackend every night 
>>> at midnight, but this still leaves me with only being able to record 
>>> 1 show a day.
>>> Any help or suggestions for things to try would greatly be appreciated!
>>> My system info:
>>> AMD 2600+
>>> MSI KTV4 mobo
>>> PVR-250
>>> Redhat 9.0
>>> MythTV from latest CVS (i've gone through several versions all with 
>>> the same problem)
>>> ivtv from latest CVS (problem also present through several versions)
>>> running at RPMs kernel 2.4.20-20_29
>>> Using ALSA sound drivers
>>> -- Sabin
>>> ------------------------------------------------------------------------ 
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> I used to get that problem, I forget how exactly I fixed it, but you 
>> may want to try using the 0.1.6 ivtv drivers available on the 
>> sourceforge project page.
>> http://sourceforge.net/project/showfiles.php?group_id=73219&package_id=73245 
>> Since I've started using them all my ivtv problems have gone away.  
>> Just checking that right now I noticed 0.1.7 is out now too, 
>> everything is working perfect with 0.1.6 for me so I don't think I'm 
>> going to risk upgrading.
>> Hope that helps a little.
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> What firmware version are you using with those drivers?
> Thanks
> Steven Potter
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I'm using either pvr250_17_21288.exe or what came default on the cd.  I 
was having a bunch of problems a couple of weeks ago with the drivers so 
I tried many different combinations, and now I can't remember which I 
ended up using.

Does anyone know if there is a way/program to find out what ivtv 
firmware version you're using?

More information about the mythtv-users mailing list