[mythtv-users] Input/output Error

jose rubio debian at nc.rr.com
Wed Feb 18 08:41:07 EST 2004

On Tue, 2004-02-17 at 16:46, Ronan wrote:
> Hello,
> I get the following error when i try to do this : cat /dev/video0 >
> test.mpg. then I get /dev/video0: input/output error.  
> When I go start look in /var/log/messages then I have the following 3
> lines
> Ivtv : i2c client addr: 0x21 not found!
> Ivtv : i2c client addr: 0x21 not found!
> Ivtv : Timeout waiting for data!
>  When I try to do (I don't know if I do good trying it) rmmod ivtv, then
> I get ivtv : device or resource busy
>  I use debian unstable with kernel 2.4.24.  And I use a wintv pvr350.
> The strange thing is that it worked before, but a few days later I'm
> getting this, so I think that my configuration is okay.  Is there
> something I could try to make it work again? How can I unload ivtv and
> load it again?  I also tried rebooting dozens of times, with no luck ;-)
> Ronan
> ----
You say it used to work before.  The question that comes to mind is
"before what?"   :-)

To unload a module you need to see if it's busy.  Do lsmod, then you'll
see that the ivtv module is being used by ivtv-fb so you need to rmmod
it first.

Here's what you should do to see where the problem is:

1- edit /etc/modules (YES, modules NOT modules.conf) and comment out all
the lines in there that have anything to do with ivtv and/or video such
as: (from my /etc/modules)

tuner type=2
saa7127 enable_output=1 output_select=0

then reboot without starting X or mythbackend.
How?  Well, here's what I do.  I use runlevel 2 for this.  cd to
/etc/rc2.d/ and delete the links in there that refer to kdm, gdm, or xdm
and also delete the link to myth-backend.  You might want to delete also
the link to mysql that way when I boot to runlevel 2 it is pretty much
barebones and I can start stuff up by hand.  Then make it your default
runlevel by editing the /etc/inittab file and changing the line:




Now when you reboot you will not load any modules, you will not start X,
and so on. To get back to the old setup just change the 2 to a 3 above.

now, load the modules one by one like so:

# modprobe i2c-core
# modprobe ivtv-fb

and see where the first error comes. (BTW, of course you have to be root
to do all of this changes)  Also, you probably do not need any
references to the above modules in your /etc/modules.conf file.

When you'd done this then tell us where the first error comes up and
what it is and maybe i can help a bit more.


More information about the mythtv-users mailing list