[mythtv-users] Lirc and Mythtv (Hauppauge Gray Remote)

Aleaxander alex at carbonated.com
Mon Feb 9 02:12:06 EST 2004

I'm somewhat of a newbie to Linux, so I beg you to bare with me as I 
describe the problem that I have run into because I've really been 
trying to figure this out on my own.  After many google searches, many 
mythtv-users searches, going back a few months on the lirc mailing lists 
archives (is there a searchable archive somewhere?) and digging around 
through lirc related directories on my system, I have not been able to 
figure out what is wrong and why my remote has stopped working.

I'm running Fedora Core 1, MythTV .13 and Lirc 0.7.0.  I installed 
MythTV and lirc using Jarod's guide a few weeks ago.  Haven't even 
considered upgrading to .14 until I figure out what is currently wrong. 
  Everything was running fine until I setup my 2nd system (the one that 
my wife does not use) to run as a MythTv slave frontend and mounted 
three folders from the MythTV backend server using NFS.  Since then, 
when I do:

$ mythfrontend &

I get these errors:

mythtv: could not connect to socket
mythtv: Connection refused
Failed to create lirc socket for mythtv

(note: I have this machine setup to automatically start the mythtv 
backend as a slave and frontend via the chkconfig command as described 
in Jarod's guide, so I wonder if this error is because I've exited the 
frontend once and tried to run it again?)

Then, when I look at lircd under the Service Configuration (yes, I know 
I should be able to figure out a better way to get the state of lircd 
than using a GUI application, but I haven't found anything yet, and 
given I'm still a newbie), it gives this status:

lircd dead but subsys locked

I can restart lircd, but the remote won't work on the frontend, and if I 
exit and restart the frontend, the status will change to the same message.

Here is the part that I don't understand (okay, maybe it is one of many 
things I haven't figured out yet...) and I'm not totally sure that it is 
the problem, but it seems suspicious.  This is the second time that I've 
had lirc fail on a system after setting up NFS to share directories 
between systems.  The first time was after I had the master backend 
server with a frontend setup configured and running fine in the living 
room (wife's primary machine) with a slave backend and frontend running 
in the bedroom.  After I setup the master backend with NFS to share the 
tv and movie directories with the slave backend and frontend the remotes 
stopped working on both systems.  I was able to restart lircd on the 
slave frontend and it worked, but no luck on the frontend on the master 
backend machine (wife didn't like this).  After working on it for about 
a week in my spare time (and teaching my wife how to use the keyboard to 
control Myth), I gave up and reinstalled everything from scratch) so 
that the remote was working again on both systems.  Then, very 
carefully, I tried NFS again.  This time, I'm having no problems with 
the remote on the master server's frontend (thank god; as far as my wife 
is concerned, everything is working fine), but the slave frontend's 
remote will not work, even though this is the same system that I was 
able to get working by restarting lircd before (by the way, everything 
works fine on the slave backend and frontend using the keyboard, and the 
remote was working fine on this system before I setup NFS, or more 
exactly, edited my /etc/fstab to auto-mount some of the directories on 
the master backend machine).

I have the feeling that I'm not giving enough information in this 
problem, so perhaps someone can recommend a way for me to get more debug 
information out of lirc that will help in identifying what is wrong?  I 
don't seem to have anything lirc related under /var/log/.

If anyone can give any suggestions on what to try next, I'd very much 
appreciate it.


-Alex Offermann

More information about the mythtv-users mailing list