[mythtv-users] lirc and FC3

Jason potuncle at enjoyingeugene.com
Tue Dec 21 17:50:16 UTC 2004

I almost tore my hair out getting LIRC to work with FC3 (2.6.9). I kept 
getting an error in the logs about CONFIG_DEBUG_SPINLOCK_SLEEP when 
running LIRC with debug. I recompiled my kernel after disabling 
CONFIG_DEBUG_SPINLOCK_SLEEP in the .config file. With that new kernel, 
IVTV was complaining about not having CONFIG_DEBUG_SPINLOCK_SLEEP 
enabled and since IVTV is a lot more important to me than LIRC, I went 
back to the origional kernel.

Finally, on a longshot (which I had tried before) I downloaded and 
compiled the CVS of LIRC and it actually worked.

For you, I'd first comment out all the lines about LIRC in your 
modprobe.conf. Then run depmod -a and reboot. Try using insmod to 
install the lirc_dev kernel module. Then insmod lirc_i2c. Now try 
running lircd -n -D[1] and see what messages you get. If lircd starts 
up, open another terminal and try running irw and see what kind of 
responses you get from lircd and irw as you are trying to send IR 
signals to it.

Hope that helps,


On Dec 20, 2004, at 8:47 PM, Andy Long wrote:

> It seems that almost everyone who has used FC3 with kernel 2.6.9 (or 
> some deviant thereof) have had problems getting LIRC to work.  I have 
> tried to get mine working, unsuccessfully.  I am following Jarod's 
> guide, and have a PVR-250 using the IR receiver that comes with it. I 
> have done the fix found here:  
> http://bugzilla.atrpms.net/show_bug.cgi?id=317  but I have not been 
> able to get it to work.  It worked after first installing it, but died 
> after the reboot (just like many other people have had problems with). 
>  I have played with some of the suggestions posted on the listserv as 
> far as reinstalling LIRC, doing a "/sbin/depmod -a" and then 
> "/sbin/modprobe lirc_i2c", and then "/sbin/service lircd restart" 
> (I've done those 3 things in various orders) but that doesn't get it 
> to work either.  Basically, when I run "/usr/bin/irw" it does 
> nothing.  If I do it again,
> Can someone please post a workaround as far as how they got it 
> working?  I'm still a n00b at this, so if you could be a bit 
> descriptive to help with my lack of knowledge with linux, that'd be 
> great.
> Thanks.
> -Andy
> FC3
> Kernel 2.6.9 (the one jarod's guide says to install here: 
> http://wilsonet.com/mythtv/fcmyth.php#kernel)
> PVR-250 w/ grey remote and the packaged IR receiver
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/enriched
Size: 3096 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20041221/898e7414/attachment.bin

More information about the mythtv-users mailing list