[mythtv-users] Just Can't Get lirc to Work :-(

Rob Rosenfeld mythtv.org at rosenfeld.to
Sun Dec 19 05:10:51 UTC 2004

David Bosiljevac wrote:

>Hi all,
>I've tried everything I can, but I just can't seem to get lirc to work for me.
>I do all the kernel compilations, with all the required modules, but when I run the
>/usr/local/bin/irw program, nothing shows up when I press buttons on the remote.
>I've checked to make sure the IR cable is plugged into my Hauppauge card.  I've
>changed batteries on my remote.  Still nothing.
>Here's the lirc entries from my /var/log/messages file:
>Dec 18 23:44:22 localhost kernel: lirc_dev: IR Remote Control driver registered, at
>major 61
>Dec 18 23:44:22 localhost kernel: bttv: driver version 0.7.108 loaded
>Dec 18 23:44:22 localhost kernel: bttv: using 4 buffers with 2080k (8320k total) for
>Dec 18 23:44:22 localhost kernel: lirc_i2c: chip found @ 0x18 (Hauppauge IR)
>Dec 18 23:44:22 localhost kernel: lirc_dev: lirc_register_plugin:sample_rate: 10
>My lircd logfile is showing the line:
>Dec 18 23:46:21 krusty lircd 0.7.0: accepted new client on /dev/lircd
>There doesn't seem to be any errors anywhere.
>Am I missing something?  Does anybody have any thoughts as to why I get nothing when
>I run irw?
>Thanks in advance.

Do you have the correct /etc/lircd.conf file for your remote?  When I 
can successfully connect with irw, meaning that it doesn't return to 
command prompt on launching and my kernel shows it accepting a new 
client, but get nothing from button presses, that means I used the wrong 
config file.  You prolly have to restart lircd after updating the config 

More information about the mythtv-users mailing list