[mythtv-users] [OT] rc.local not running

PAUL WILLIAMSON pwilliamson at mandtbank.com
Mon Dec 13 21:44:03 UTC 2004

>>> jarod at wilsonet.com 12/13/2004 4:16:23 PM >>>
>/etc/rc.local is a symlink to /etc/rc.d/rc.local on my boxes, created
>install time... However, I'm not certain that the variable is actually
>for anyone but root, using a true root shell (either by logging in as
root or 
>using 'su -'). Might be better to stash that in both
>and /home/mythtv/.bash_profile instead.

Well, that explains why it was working fine for me.  I tried this as 
root, without thinking it's different for a regular user.  Tried it by
logging in 
as mythtv and sure enough, it's not set.  Changed the setting in 
~/mythtv/.bash_profile, logged out and logged back in, and all is

Although, any time I'd need the version of the kernel, I'd be root 
anyway.  I'll just leave it in /root/.bash_profile and that should be 
fine.  MythTV will probably never need to know the kernel version.


More information about the mythtv-users mailing list