[mythtv-users] database connect problem...

htpc htpc at treblid.dyndns.org
Thu Dec 9 04:45:43 UTC 2004

Just wondering, did you install/build the QT plugin for MySQL?

E.g. on my Mandrake system, I need to install 
to get that library.

travis eddy wrote:

> yep i have the share mysql.txt and the ~/.mythtv/mysql.txt
> the error
> [blur at smokey blur]$ mythfrontend
> QSqlDatabase: QMYSQL3 driver not loaded
> QSqlDatabase: available drivers:
> QSqlDatabase: QMYSQL3 driver not loaded
> QSqlDatabase: available drivers:
> Unable to connect to database!
> No error type from QSqlError?  Strange...
> couldn't open db
> last time i got that error was when i first set up a frontend only 
> box, and i learned to edit the mysql.txt files.. i edited them and did 
> everything else i could find in the docs.
> everything related to mysql is installed. it worked before so i have 
> no idea why it isn't working now
>> From: Kevin Kuphal <kuphal at dls.net>
>> Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
>> To: Discussion about mythtv <mythtv-users at mythtv.org>
>> Subject: Re: [mythtv-users] database connect problem...
>> Date: Wed, 08 Dec 2004 21:22:02 -0600
>> travis eddy wrote:
>>> hey, also all the master backend settings check out ( like the ips 
>>> in ./setup)
>>> also if i hit '#mysql -u mythtv -p mythconverg -h giger' and enter 
>>> mythtv for the password it works! i can get in.... so where is the 
>>> problem?!!?!?!?!?!?!?!?! i have never had a problem like this 
>>> before, i think mandrake is starting to turn in to windows with 
>>> mysteris unexplaneable problems......
>>>> From: "travis eddy" <boscotwo at hotmail.com>
>>>> Reply-To: Discussion about mythtv <mythtv-users at mythtv.org>
>>>> To: mythtv-users at mythtv.org
>>>> Subject: [mythtv-users] database connect problem...
>>>> Date: Thu, 09 Dec 2004 01:33:45 +0000
>>>> hey guys,
>>>> i have set up a remote frontend a number of times so don't ask me 
>>>> whats wrong :-p...
>>>> allright i edited the /usr/local/share/mythtv/mysql.txt like normal 
>>>> and put in the masterbackends hostname ( which worked every other 
>>>> time fine) accept this time i still get the can connect error... so 
>>>> on the other maching i looked for the my.cnf, but can't find it ( 
>>>> figured mandrake install has is hidden) i check all the mysq 
>>>> folder, and the mythconverg folder, no where to be seen. i was 
>>>> going to make on put i don't want it messing up my backend.
>>>> anyone know why my fontend dosen't want to connect?
>> Maybe you could post the actual error message you are getting.  Also, 
>> do you have a mysql.txt in your ~/.mythtv directory that might be 
>> overriding the local/share one?
>> Kevin
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list