[mythtv-users] recording blank, only with mythtv

Cedric Tefft cedric at phreaker.net
Sun Aug 22 03:18:41 EDT 2004

Henrik Bentel wrote:

> Hi
> I have strange problem. If I cat out /dev/video0 to a file, I can play 
> it using mplayer. If I just watch live TV using mythfrontend 
> everything is just fine.
> BUT, if I record with mythtv, even just a minute, mythtv records only 
> blank/black. And if I go back and cat out /dev/video0 again into file 
> it also now records blank/black.
> I have a script that I run as part of rc.local which runs 5-6 
> test_ioctl commands (sets width, height, frequency, input, output, 
> tuner, etc). If I run this script manually after recording goes 
> blank,  everything is fine again. But as soon as I record something 
> using mythtv, it seems something gets unset or set incorrectly and I 
> record nothing but blank.
> When a recording starts I see in message log messages indicating 
> mythtv is resetting some settings. The messages are "setting NTSC 
> width" and "setting NTSC height".
> These are the same messages that show up if I run my script containing 
> the test_ioctl commands manually.
> I've had mythtv up and running just fine since 0.13. Due to crappy 
> maxtor drive saying good night I recently had to reinstall(Only 
> Seagate w/5 year warranty from now on).
> Luckily I was able to backup the DB, all important config files from 
> /etc and mythtv users home directory. So my software configuration is 
> pretty much identical to before the reinstall. And my hardware(except 
> the maxtor) is also identical.
> any ideas?
> thanks,
> Henrik Bentel
>mythtv-users mailing list
>mythtv-users at mythtv.org
Kinda sounds like the scheduler is picking a non-productive input on 
your tuner card.  For instance:  let's say you've got a PVR 250 and 
you're watching live TV on the tuner input, but you've told MythTV that 
you also have input on the S-Video input when in reality there's nothing 
connected to it.  The recorder may be switching input to the S-Video 
input (to which there's nothing connected) and you get black/blank 
thereafter.  I'd run the backend 'setup' program again, go to 'Input 
Connections', and make sure you have a video source associated ONLY with 
the input(s) which actually have valid signal(s) on it/them.  The rest 
of the inputs should say '(none)'.

- Cedric

More information about the mythtv-users mailing list