[mythtv-users] Re: recording blank, only with mythtv

Henrik Bentel hbentel at comcast.net
Fri Aug 20 19:46:43 EDT 2004


>I have strange problem. If I cat out /dev/video0 to a file, I can play it 
>using mplayer. If I just watch live TV using mythfrontend everything is 
>just fine.
>BUT, if I record with mythtv, even just a minute, mythtv records only 
>blank/black. And if I go back and cat out /dev/video0 again into file it 
>also now records blank/black.
>I have a script that I run as part of rc.local which runs 5-6 test_ioctl 
>commands (sets width, height, frequency, input, output, tuner, etc). If I 
>run this script manually after recording goes blank,  everything is fine 
>again. But as soon as I record something using mythtv, it seems something 
>gets unset or set incorrectly and I record nothing but blank.
>When a recording starts I see in message log messages indicating mythtv is 
>resetting some settings. The messages are "setting NTSC width" and 
>"setting NTSC height".
>These are the same messages that show up if I run my script containing the 
>test_ioctl commands manually.
>I've had mythtv up and running just fine since 0.13. Due to crappy maxtor 
>drive saying good night I recently had to reinstall(Only Seagate w/5 year 
>warranty from now on).
>Luckily I was able to backup the DB, all important config files from /etc 
>and mythtv users home directory. So my software configuration is pretty 
>much identical to before the reinstall. And my hardware(except the maxtor) 
>is also identical.
>any ideas?
>Henrik Bentel
>mythtv-users mailing list
>mythtv-users at mythtv.org

More information about the mythtv-users mailing list