[mythtv-users] correct way to use new screen size switching

James Armstrong james at thearmstrongs.org
Sat Aug 21 18:13:27 EDT 2004


I have been trying to get the video playback size to change based on the 
video content. I usually just play everything on my screen size setting 
of  888x508. I enabled the use separate gui / playback options in the 
cvs version from a few days ago. I have the gui size set to 888x508 to 
match my modeline. I have the default playback set to 888x508, and the 
video1 option of a source of 1920x1080 and a modeline of 1856x1080.  It 
always seemed to use the 888x508 mode even when I playback a HD 
recording that I know is 1920x1080. I saw that XFree86 was complaining 
about not having a virtual screen size to match the 1920x1080 mode.

I changed my default mode in the XFree86 config to 1856x1080 then when 
mythfrontend starts it switches the screen to 888x508 and it looks good. 
It was still playing video in 888x508 and not switching. I changed to 
default playback size to 1856x1080 just to see what it would do. It 
switched to 1856x1080 on playback but the video was only in the top left 
quarter of the screen. When I select the HD content of 1920x1080 it also 
played in the upper left corner. The video looked like it may have been 
scaled to fill the whole screen but only the top left was showing, with 
the rest of the screen filled with the normal tiled myth background. 
What am I missing?

- James


More information about the mythtv-users mailing list