[mythtv-users] [mythtv] Audio Woes

Ben Matthew ben at thelemite.freeserve.co.uk
Thu Aug 19 02:13:09 EDT 2004


Being getting really damn close to getting a good mythtv box up and
running but have come unstuck when it comes to audio and, I believe,
this problem is spilling over into other problem areas as well.  I've
tried everything I can think of so was wondering if anyone here had any
ideas.  First my system:

EPIA VIA MII10000 mini-ITX motherboard
 - Onboard AGP Castlerock graphics
 - Built in MPEG2 decoder via CLE266 chipset
 - Onboard 6CH Audio (SPDIF out); via82xx chipset

Hauppauge WinTV NOVA-T DVB PCI card

Fedora Core 2 base installation upgraded to 2.6.7 kernel
epia1 kernel patch applied from epiawiki.org

Unichrome opensouce driver for video card; both XFree86 and kernel DRM -
latest from CVS

XFree86 4.4.0; dri enabled ok; configured for PAL TV Output (768x576 or

OK; when using the OSS sound system that comes with 2.6.7 my audio
chipset is detected fine; normal audio players work fine and mplayer is
more than happy to play back my video files in stereo sound.  I
originally built mythtv from the tar ball distro (0.18), enabling DVB
support, ALSA support, CLE266 support and LIRC support.  Under this
environment mythtv plays back sound fine but whenever I go to exit back
from either live tv or a recorded program approximately half a second's
worth of samples seem to get stuck in a loop jamming the system for
about 5 seconds; "dah-dah-dah-dah-dah..." to be scientific.  Then
mythfrontend reappears and everything returns to normal.

I then experiemented with ALSA because, ideally, I want the sound to be
coming out of the SPDIF anyway and, even more ideally, to enable the AC3
passthrough as I have a DVB tuner.  I installed the latest stable ALSA
drivers and library, 1.0.5, and then configured mythtv to use
"ALSA:iec958" as its audio device.  Now whenever I select live tv or
attempt to watch a recording I get the first frame appear followed by
the same problem as above, a loop of around half a second of audio.
However this time the whole system freezes totally, I can't even exit.
As a test I played back a video file with mplayer using "-ao
ALSA:driver=iec958" and everything played back fine through the SPDIF
output.  In fact I have had mplayer playing back full 6 channel audio in
this way.  No audio issues at all.

When I upgraded mythtv to the latest from CVS this behaviour altered.
Now when outputing with ALSA:iec958 everything plays back fine and dandy
through SPDIF for 10 seconds; then I lose audio.  The output from
mythfrontend tells me that the audio device opened ok; then 10 seconds
later it reports "broken pipe".  I also changed the output to
ALSA:hw:0,0 which outputs to the normal analog stereo output and the
effect is the same as with the digital.

The other major pain in the arse is when it comes to fast forwarding; I
can get away with it for seeks of about 1 minute but if I try,
regardless of seek speed, to fast forward for anything over about 5
minutes the system will black screen me and freeze.  I believe this may
well be related to the audio problem; because myth is attempting to
resync a broken audio stream with the video.  Just a guess mind.

I have tried several versions of ALSA in case I was using a too new
version; I tried using ARTS (as I run KDE desktop); I've tried
recompiling myth - all to no avail.  I'm not running the artsd server
(unless I was attempting to use the arts support obviously); in fact
I've even gone as far to run mythtv with nothing else running besides X
and twm so I know it's not some little bugger of a program running
without my knowledge.  Disabling CLE266 support made no difference.
Using aggressive soundcard buffering made no difference. 

I've also tried applying a couple of the patches for AlsaAudioOutput
posted to this list with some interesting results.  The patch posted in
the thread:
aded ; causes my system to re-open the audio device after it drops out
after 10 seconds.  It does this successfully for a couple of attempts
and then mythfrontend will seg fault.  Curiously I noticed Isaac said
he'd applied the patch to CVS yet this doesn't appear to be my

If anyone has any suggestions how I can sort this I'd be very grateful
as it's so frustrating to be so close and yet still have a practically
unusable system.  The thing I don't get is why ALSA works so perfectly
with mplayer and yet is such an issue with myth.


Ben Matthew

-------------- next part --------------
mythtv-dev mailing list
mythtv-dev at mythtv.org

More information about the mythtv-users mailing list