[mythtv-users] thing won't record.. *more info*

Craig Tinson craig at 8010.co.uk
Sun Aug 1 08:50:17 EDT 2004

Michael T. Dean wrote:

> Craig Tinson wrote:
>> Craig Tinson wrote:
>>> ...
>>> am confused as to why things would appear in the "recording 
>>> schedules" table but not then actually get recorded.. and why once 
>>> they are in recording schedules why they don't get to "scheduled 
>>> recordings"..
>>> ...
>> ok.. bit of an update.. I'm *completely* uninstalled Myth.. rpm -e'd 
>> everything.. then removed everything from mysql..  then started again 
>> from scratch.. *exactly* the same problem!
> Usually a complete uninstall followed by a re-install with the same 
> results points to a configuration problem--unless "everyone else" is 
> having the same problem.  In these cases, it's usually been 
> reconfigured incorrectly or some "sticky" configuration settings have 
> carried over.
>> I *have* set everything up in mythtvsetup correctly.. (this must be 
>> about then 20th time I've installed myth.. I know the steps.. lol)
> You keep assuring us that you've set everything correctly.  Therefore, 
> there's little we can do to suggest a fix.  Since Myth is working fine 
> for thousands of other people, it's unlikely to be a bug--and if it is 
> one, much more information is needed to positively identify it.
> So, how about telling us *how* you've configured Myth--instead of 
> telling us it's configured correctly?  The people on this list are 
> very forgiving:  we won't hold judgement against you even if you did 
> configure it incorrectly. ;)
> I recommend starting with the configuration of your Input Connections 
> and your hardware setup (i.e. which card you're using, which tuner 
> (internal or external) you're using, which cables are plugged in to 
> which ports of your card, etc.).  Give us some information instead of 
> "it's configured correctly, but it doesn't work," and we'll give you 
> some feedback.
>> am I *really* going to have to flatten the whole box and re-install 
>> linux too to get this working? I can't believe it should come to 
>> that....
> That's never required.  Once you identify the problem, it's possible 
> to fix it.  Identifying the problem requires a systematic approach to 
> verifying configuration settings, observed behavior, and observed 
> failures--and, generally, requires many eyes to verify these things.
> Mike
> P.S.  I'm not picking on you.  A lot of people on this list seem to be 
> saying the same thing.  However, "It's configured correctly," actually 
> means, "It looks to me like it's configured correctly," and that 
> doesn't help anyone...  Since I'm responding to you and ignoring at 
> least three other threads where people are doing the same thing, I'm 
> far more likely to continue helping to solve your problem than the 
> others...
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

your right.. my apologies.. just got on edge a bit as this has been
bugging me for a couple of days now and not been able to get my head
around it..

ok.. my setup... and since the last post I *have* flattened linux and
re-installed.. and got the same problem.. so your right.. it *must* be a
configuration problem...

single box.. backend and frontend..
athlon 2.8ghz,160gb,512Mb,radeon 9200se.. and an AverMedia Studio (bt878
based card) on /dev/video0 running on FC1 as per Jarod's (excellent)
am in the UK and am using Sky as a provider..

so quite a simple setup.. and I've flattened and re-installed this
dozens of times with no problems.. (hence the frustration)

the radeon card is running out through composite to a sanyo 28"
widescreen... no problems there.. ATI (fglrx) drivers seems
to be running a treat...

am running tv_grab_uk_rt xmltv grabber as follows:
/usr/bin/tv_grab_uk_rt --slow --days 1 --get-categories --limit-details
20:00-00:00 > ~/sched.xml
mythfilldatabase --file 2 0 ~/sched.xml

to test things... and the EPG is looking all nice and friendly.. (took
*ages* to figure that part out.. lol).. running xmltv this way (without
the limit-details) has worked perfectly in the past.. so am not looking
at that as a problem.. (unless RT have changed something but that is
unlikely as the EPG looks fine and populates fine)

during the mythtvsetup I used all defaults.. except for setting capture
card to use "composite" as a default.. I've tried setting the ip's to
both and (usual ip for the myth box).. but that
doesn't make any difference... video source is set to Sky (via
tv_grab_uk_rt) and the input connections are set for composite to Sky..
so all basic stuff..

when I try to schedule a program to record.. I can see it's gone into
the "record" table.. and I can see it under "recording schedules" in
mythweb but not "scheduled recordings".. and it's not highlighted in the
EPG and doesn't record..

thats about all the info I can get together at the moment.. apart from
the mythbackend log that I posted previously..

thanks for the patience guys.. hope I can get this figured out with your



More information about the mythtv-users mailing list