[mythtv-users] patching OS X mplayer (was: Re: [mythtv] Front ends for other machines)

Cedar McKay cedarmckay at mac.com
Sat Mar 29 08:38:56 UTC 2003


thats ok. I make mistakes like that all the time. I tried using matt's  
patch agains rc5 but it didn't apply cleanly. It did apply to rc4. I  
first tried to compile the patched rc4 with "./configure --enable-gui"  
but the compile failed. I tried again with just ./configure make make  
install" and it compiled without errors.  However with the command  
"mplayer targetfile.nuv" I got a lot of cpu and disk activity and the  
output below. I'm not putting much effort into this project, so I don't  
know if I missed some pre-requisites, or needed to compile with some  
different options. As far as prerequisites, all I have is the 10.2  
developer tools, and the latest apple x11 (and x11 SDK for headers and  
such) installed. Let me know if you figure anything out.



cedar

Sample output:
[homer:~/Desktop] cedar% mplayer 1022_20030317003000_20030317010000.nuv

MPlayer 0.90rc4-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file  
or directory
Reading config file /Users/cedar/.mplayer/config
Reading /Users/cedar/.mplayer/codecs.conf: can't open  
'/Users/cedar/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 135 video codecs
font: can't open file: /Users/cedar/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using usleep() timing
Can't open input config file /Users/cedar/.mplayer/input.conf : No such  
file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No  
such file or directory
Falling back on default (hardcoded) input config

Playing 1022_20030317003000_20030317010000.nuv
NuppelVideo file format detected.
NUV extended frame does not have expected length, ignoring
No NUV extended frame, using defaults
======================================================================== 
==
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, 16 bit (0x20), ratio: 176400->176400 (1411.2  
kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
======================================================================== 
==
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
[vo_gl] Using 4 as slice_height (0 means image_height).
vo: couldn't open the X11 display ()!
vo: couldn't open the X11 display ()!
======================================================================== 
==
Opening video decoder: [nuv] NuppelVideo decoder
VDec: vo config request - -536805376 x -536805376 (preferred csp:  
Planar I420)
Could not find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
swScaler: -536805376x-536805376 -> -536805376x-536805376 is invalid  
scaling dimension
Couldn't init SwScaler for this setup
FATAL: Cannot initialize video driver.
VDecoder init failed :(
*** Try to upgrade /Users/cedar/.mplayer/codecs.conf from  
etc/codecs.conf
*** If it still does not work, read DOCS/codecs.html!
Cannot find codec matching selected -vo and video format 0x3156554E.
======================================================================== 
==
Checking audio filter chain for 44100Hz/2ch/16bit ->  
44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, big endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Big-Endian)
using device Built-in audio controller for output:
         with sample rate 44100.000000, 2 channels and 32-bit sample
using device Built-in audio controller for input:
         with sample rate 44100.000000, 2 channels and 32-bit sample
AO: [esd] 44100Hz 2ch Signed 16-bit (Big-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit ->  
44100Hz/2ch/16bit...
Video: no video
Starting playback...

Too many video packets in the buffer: (1 in 321213976 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
A:   0.0  0.0% 0%

Exiting... (End of file)





More information about the mythtv-users mailing list