[mythtv-users] install help

Jay jsprenkl at zenobia.ettu.net
Sun Mar 23 23:54:34 UTC 2003


Edward Wildgoose wrote:
> Well, it isn't mythtv as such which is causing the crash.  Seems that some
> module that myth is using is causing the problem.
> 
> Suggest first debugging the problem outside of mythtv.  First use lavrec
> from mjpegtools to record from the card.

I wasn't trying to record, just view tuner output.
Are you suggesting recording something since it accesses the tuner
card in the same way that mythtv does?

> 
> Also check that the machine is really locked, does the capslock/numlock
> light come on when you hit the key?  It could be just that myth has taken
> over the screen and crashed leaving a black picture up...?  Hit control-alt
> 1 to get a text console up, log in there and kill myth to get control back

Thanks. I knew about control-alt-backspace but not that key combo.

> 
> 
>>I did not install xml tv (I have the same problems other do with it.
>>Cpan does not work and I couldn't find all the dependencies)
> 
> Well, if you didn't install all the bits, then that is definitely a
> problem...  If CPAN doesn't work then you can always download manually from
> CPAN (http://search.cpan.org) and then unpack and install it yourself

Since it's only supposed to read the tv guide data and channel names
from these files why would they cause the application to crash if
they're not present? Doesn't mythtv have sane defaults or error
handling?

On installing xmltv:
I tried going to the cpan site. I tried searching for the modules
I was told I needed. There were 10's of thousands of modules present,
none of which matched the name given in the document I looked at when
I tried to install it. I later found you have to know the correct
prefix which isn't mentioned anywhere and is only obvious if you're
a perl programmer.

<soapbox> I don't see what's so damn hard about packaging all
the requirements for xmltv into one file and making an install
script to install what a user does not have. CPAN is a stupid
idea. </soapbox>


> 
> Did you setup mysql and add in the schema entries?

I ran the sql script provided which did not produce any
errors.

> 
>>"mythfilldatabase --manual" does nothing but give errors.
> 
> Probably because stuff is missing?

The manual option is given as a method of entering the
stuff it reads from the (missing) xmltv files. Someone
went to the trouble to put in an option to allow me to
enter the missing bits, someone else went to the trouble
to document, I thought I'd go to the trouble to put in
a bug report that it wasn't working. Again why isn't
there decent error handling present?

If you don't like answering stupid newbie questions
please just refrain from being impolite about it?




More information about the mythtv-users mailing list