[mythtv-users] rpms for Mandrake

Michael J. Sherman msherman at dsbox.com
Thu Mar 6 16:43:02 UTC 2003

If you're SSHing into the myth box and trying to run the command from 
the SSH session, X will try to open the program on your local console, 
and not on the myth box.  I tried this last night.  I have a Linux box 
in my office, and the myth box is in my living room.  On my office 
machine, I logged in (X session open), brought up a terminal, and SSHed 
to the myth box, and then ran 'mythfrontend'.  It then popped up the GUI 
onto my office machine desktop, and NOT the myth box.

This is the default behavior for X, BTW.  It tries to open the app on 
your local console from which you ran the command.  That's what makes X 
so cool, actually.  In order to get it to show up on the remote machine, 
I think you need to give the program an additional 
-display=localhost:0.0 or equivalent option, depending on whether or not 
the app will accept and process standard X command-line args like 
display, geometry, etc.

Therefore, if you're SSHing to your Myth box from a Windoze box or 
something with no X server, you'll get the "Cannot connect..." error.


Ray Olszewski wrote:
> At 11:18 PM 3/5/2003 -0800, skeeterskip wrote:
>> Yeah, I have computer in living room right now and I
>> do most of work from machine in another room. I use
>> program called Putty which does ssh.
>> I can try the commands locally from living room, but
>> am pretty sure I get the same thing.
> "pretty sure" doesn't count when troubleshooting. Try it, and tell us if 
> it works or not. If it fails with a *different* error, tell us the exact 
> error message.
> If you are accessing your Myth host from a remote host that runs X, you 
> should be able to tunnel X through ssh or even run it untunneled. 
> (MythTV might not work well this way -- I've not tried it -- but it 
> should at least be willing to make the initial connection to the X 
> server.) But Putty is a Windows app, and Windows systems are not 
> *usually* running X servers, with the consequence that there is no X 
> server for mythtv or mythfrontend to connect to. Hence the message you 
> report seeing.
> What you should do is go to the actual MythTV host, and start X on it 
> under the userid mythtv (don't let Mandrake and KDE push you around here 
> ... automatically starting X as root is a configuration error of some 
> sort). Then open an xterm (or KDE's equivalent, probably a kterm if it 
> follows the usual naming convention for KDE stuff). From the xterm, run 
> "mythfrontend".
> If you encounter a problem with *this* procedure, post a followup that 
> describes it specifically, including the exact error output you see in 
> the xterm.
> If you are running an X server on the Windows host, we may be able to 
> help you get mythtv running to it. But not until you have verified that 
> mythtv and mythfronend work property in the simpler, same-host setting 
> ... with troubleshooting, it's always wise to solve one problem at a time.
> In any case, to troubleshoot the remote-X problem, we'll need the 
> details of *how* you have X running on Windows (what version of Windows, 
> what X server, what userid, what provisions for remote access, what 
> arrangements for ssh tunneling).
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at snowman.net
> http://www.snowman.net/mailman/listinfo/mythtv-users

Michael J. Sherman  |  Software Developer
Digital Sandbox, Inc.  |  http://www.dsbox.com/

More information about the mythtv-users mailing list