[mythtv] Ticket locking and a PulseAudio fix

James Le Cuirot chewi at aura-online.co.uk
Mon May 9 12:36:30 UTC 2011

Hello all,

I wish to express my concern at how tickets are sometimes being handled
by the developers, in particular with regard to how PulseAudio users
are being treated as second-class citizens. Now I know that some of you
have strong opinions about PulseAudio and you are obviously entitled to
those opinions. You are even entitled to refuse your time to work on
PulseAudio issues yourselves but please do not lock such tickets
without good reason. This prevents users from talking about these
issues or even providing possible fixes without posting to this list as
I am doing today.

The issue at hand is http://code.mythtv.org/trac/ticket/9579. Pausing
playback currently causes one CPU core to use up 100%. jyavenard simply
locked the ticket stating that using ALSA:pulse works for him.
Admittedly this does, at least at first glance, seem to work a lot
better than it used to but this should not be considered a proper fix.
As it turns out, the problem has nothing to do with PulseAudio itself
but appears to be the result of a short-sighted commit, also by


This second hunk was added for http://code.mythtv.org/trac/ticket/8894
though it's not clear whether this was what actually fixed it in the
end. In any case, it short-circuits all the actual PulseAudio code when
paused so it's no wonder the CPU hits 100%. I have tried removing these
lines and it does fix the issue with no sign yet of any "static blast".
These lines are not present in master, only fixes/0.24.

Sending silence to the card seems like a strange way to pause the
stream to me and maybe pa_stream_cork() would be a better solution but
I'm not an audio coder so maybe that's not appropriate.

PulseAudio tickets are not the only ones being prematurely locked.
http://code.mythtv.org/trac/ticket/9357 regarding BBC iPlayer not
working in MythNetvision was also swiftly locked with no opportunity
for discussion. Mythbuntu is not the only distribution seeing this
issue as I am also experiencing it on Gentoo. What is especially
interesting is that it works when I browse to the iPlayer site with
MythBrowser. I gather MythNetvision uses MythBrowser so it must be
doing something differently. Could you therefore please reopen it. If
it helps, the error message recorded by Flash itself is...

Title: GenericKind:FMSConnectionError.FMS_CONNECTION_API
 Description: CDN Failover, final connection failed
 Code: 222222

Please do not take this message as a rant. I'm just raising concerns
and I hope that something positive will come out of it.


More information about the mythtv-dev mailing list