[mythtv] AC3 playback mangled until timestretch activated

Jean-Yves Avenard jyavenard at gmail.com
Sat Feb 27 06:42:13 UTC 2010


On 27 February 2010 16:07, Yeechang Lee <ylee at pobox.com> wrote:
> After further testing with the original _Tonight_ recording, the
> changeset force upmixes the two-track AC3; if I turn the upmixer off
> via the OSD, the receiver's display switchs to Pro Logic II. Before
> the changeset, with the workaround (using timestretch to switch away
> from, then back to, 1.0X) the audio signal is unchanged.

What was your expected behaviour ?

> This is visible via the sample clips. It is not possible to switch the
> upmixer off with conan.mpg and conan3.mpg, but is possible with
> conan2.mpg and conan4.mpg.

but conan.mpg and conan3.mpg are seen as having a AC3 5.1 track ; so
upmixer on or off will make no difference.

What is important is the first track seen.
conan2 and conan4 are seen as 2 -> 6 -> 2 -> 6 -> 2 -> 6
While conan.mpg and conan3.mpg are seen as 6 -> 2 -> 6 -> 2 -> 6

If you activate the -v audio and look at the change of the number of
channels in the AC3 track.

You'll see that for conan2 and conan4 , 2 channels AC3 is seen for
several frames, but 6 channels AC3 is only seen for 1 frame only and
vice-versa for conan.mpg and conand3.mpg

So as far as I can tell, it is behaving just as it is supposed to ;
and I can't see the difference on my system between using the
timestretch workaround or the new changeset.


More information about the mythtv-dev mailing list