[mythtv] [RFC v2] New Win32 build script

treblid treblid at gmail.com
Tue Dec 28 04:07:04 UTC 2010

On Sun, Dec 26, 2010 at 4:58 PM, treblid <treblid at gmail.com> wrote:
> Would appreciate any pointers. Thanks merry Christmas and a happy new
> year to all.
I'm well and truly stuck in this one. Tried to do a debug build of
MythTVw32 to see if I can get a backtrace but hit this problem:

C:\MinGW\msys\1.0\bin\make.exe: *** couldn't commit memory for cygwin
heap, Win32 error 0
make[3]: *** [release] Error 1

All my machines are 2GB, and only the Myth backend is 8GB, but I've
tried creating a virtual machine giving it 4GB of memory and it still
failed. :( Try increasing the heap_chunk_in_mb registry setting to
1024 and didn't help. Will try it again on my last machine (Win7
32bit) and see if it'd work there.

Any pointers? Failing that, can somebody who has a working mingw build
a debug version of the master branch and put it online somewhere for
me to download?


Ps: Apologies if this should be in the user list.

> Regards.
> On Mon, Dec 13, 2010 at 10:45 PM, Dan Wilson
> <dwilson at solidstatesoftware.com> wrote:
>> On 12/13/2010 02:01 AM, Lawrence Rust wrote:
>>> What does ftp.exe --version report?
>> $ ftp.exe --version
>> ftp (GNU inetutils) 1.7
>> Copyright (C) 2010 Free Software Foundation, Inc.
>> License GPLv3+: GNU GPL version 3 or later
>> <http://gnu.org/licenses/gpl.html>.
>> This is free software: you are free to change and redistribute it.
>> There is NO WARRANTY, to the extent permitted by law.
>> Written by many authors.
>>> This could be a temporary problem with ftp://mirror.cict.fr which is the
>>> URL in the script for wget.  Maybe try:
>>> WINGET_URL="ftp://ftp.gnu.org/gnu/wget/wget-1.11.4.tar.bz2" ./mythbuildw32
>>> If not then maybe some tcp/ip or nat problem with vmware?
>> The mingw installer script was able to download and install mingw without
>> any issues.  I was able to use a web browser to retrieve the file from the
>> location specified, but couldn't convince ftp.exe to do it. There must be
>> something about ftp.exe and this environment.... I'll play with it some more
>> and see if I can figure out why it doesn't work.
>> After manually retrieving wget and dropping it in the mythbuild directory,
>> the script successfully extracted and compiled wget.  It's now busy
>> downloading lots of files.
>>> There's a revised script to work around these path problems here:
>>> http://www.softsystem.co.uk/download/mythtv/mythbuildw32-2
>> I'm unable to connect to the site - firefox times out.  I can ping it,
>> however.  I'll try again later.
>> Thanks!
>> Dan.
>> _______________________________________________
>> mythtv-dev mailing list
>> mythtv-dev at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list