[mythtv] Error running win32-packager.pl

Rob van Geloven rob at nightsky.nl
Thu Jul 17 12:25:33 UTC 2008

I tried downloading the 2.3.7 version as suggested by Jonathan, which kind
of worked: it crashed a bit later. I cleaned the sources of both and the
downloads a couple of times. And tried again with the 2.3.5 version when
all of a sudden it completed the step. It did take me 3 - 4 tries of
delete all traces of freetype and try again. It's a bit hard to reproduce,
it almost seems as if the buildscript for freetype is biting the .pl
script or vice versa. Ie, freetype is not completed yet but the pl script
is trying to go on.

Also out of curiosity: why is the manual enter-button-pushing needed? It
seems to me that is rather useless and inconsistent if it's only done
every X step. Yes, I was slightly annoyed to come back after "waiting a
few hours (wiki)" to find it needed me to push a button.

Cheers for all the help!

Kind regards,


> buzz wrote:
>> Jonathan,
>> you could also diagnose this problem further by manually performing
>> the last few steps, and seeing if you get a bettter understanding of
>> what is goinf wrong...
>> eg, with the error you gave:
>> shell:C:\MSys\1.0\bin\bash.exe -c "( export
>> PATH=/bin:/mingw/bin:$PATH;cd /sourc
>> es//freetype-2.3.5;make) 2>&1 "
>> make: ver: Command not found
>> make: type: Command not found
>> make: *** [dos_setup] Error 127
>> ...I would do this:
>> open a MSYS window (to run bash)
>> type the following:
>> export PATH=/bin:/mingw/bin:$PATH
>> cd /sources//freetype-2.3.5
>> make
>> It could be as simple as your /mingw folder being incorrectly mounted
>> (see c:\msys\1.0\etc\fstab )
>> or the /sources folder (actually at c:\msys\1.0\sources ) being broken
>> somehow,
>> or the .tar.gz of freetype being incomplete?
> I could do, but this is not my error... it was just my suggestion.
> In my case the 2.3.5 version could not be downloaded (404 error) where
> the 2.3.7 version was availabe, so instead I went with the latest stable
> release (2.3.7) and everything went OK after that.
> Kind regards
> Jonathan
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list