[mythtv] --as-needed fix from Nigel

Anton Farygin rider at altlinux.com
Fri Jan 18 09:54:25 UTC 2008

     Fix for the fix for ld --as-needed (an anti-fix?).
     Can't depend on something that might not be built yet.
     Interesting that a --as-needed build and rebuild had no problem,
     but that a non-as-needed build failed. A very strange linker option!

Nigel, commit 15478 not fixes build with --as-needed linker flag.

For fix this problem, you need remove circular depends from libmyth / 
libmythui and same for libmythupnp.


More information about the mythtv-dev mailing list