[mythtv] Shouldn't MythTV disable the tuner between switching inputs?

Cal cal at graggrag.com
Mon Jan 7 01:27:56 UTC 2008

Sam Logen wrote:
>> --- Cal <cal at graggrag.com> wrote:
>>> Given that the ivtv drivers went into the kernel
>>> sources with 2.6.22,
>>> can I ask what kernel version you're using?  I've
>>> been trying a little
>>> bisection exercise on kernel versions to try to
>>> identify where it stops
>>> working (on my system at least), and so far the
>>> results are a little
>>> puzzling.
>>> Cheers.
> Hi, thanks for the reply.  I can't really say about
> that because I'm using the IVTV drivers from v4l's hg
> repository (rev. 6837 - necessary due to my other
> hardware testing).  If you still want to know, my
> kernel is  2.6.23-gentoo-r3.
> Best of luck,
> Sam
> PS.
> I know that it was Hans from IVTV & V4L dev. that made
> the change in the driver.  It was because switching
> the inputs before the tuner is disabled would lead to
> corrupt mpeg streams.  Perhaps I can contact them and
> ask them when the change occurred in the kernel
> versions.

I figured your issue might be a little different to mine. From what I can
tell, my system is fine with kernel.org kernels through to (the
latest), but falls apart at 2.6.24-rc1. That point may well be a partial
answer to Daniel K's question as to when the driver changed problematically.
And of course, there's a network driver introduced in the 2.6.24-rc series
that I need ... sigh.

Good luck.

More information about the mythtv-dev mailing list