[mythtv] Problems with Win32 port script

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Sat Aug 16 09:14:17 UTC 2008

> -----Original Message-----
> From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-
> 1.       When I run MythInstaller.bat, it downloads and executes
> win32packager.pl, but immediately after pressing [Enter] at the config
> summary the script appears to drop back to a command prompt—I say
> ‘appears’ because no matter what command I give next (even just
> pressing enter again) will execute win32-packager.pl. Just slightly
> confusing…

> 2.       MySql essentials is now up to version 5.0.67 (vs. 5.0.45 in
> the script), so the initial download attempt failed. I edited win32-
> packager.pl to the new version and re-ran win32-packager.pl

I ran into this problem too when i tried to compile the win32 port.

I was trying to build 0.21-fixes by using -b and uncommenting the build
number for 0.21.

First problem I ran into was with unzip.
What happened was that it extracted the files on the wrong drive.
The reason for that is that I had the win32packager.pl script on a different
drive and the current working directory was on D: instead of C:

So changing drive to C: and then starting the script again made it do the
right thing.

Next problem was the mysql problem above, installing mysql manually fixed it
for me.

Then when it came to compilation of qt3 it ran all compilations in parallel
(make -j or similar) and that resulted in 1000s of files being compiled in
parallel completely locking my computer for several hour, couldn’t even move
the mouse pointer.
My computer is a fast one too, 4gb ram and an amd dual core cpu.

then when it came to running mythtv configure it craped out because there is
no option --runtimeprefix to 0.21-fixes config so I had to remove that part
from the config command.

Then it went on to successfully build mythtv but I don’t  think the lib
files ended up in the correct place, all mythtv lib files ended up in
C:\mythtv\build\bin and when it builds mythplugins it cant link against
libmythtv-0.21 and there for fail.

That’s as far as I got and I don’t know how to fix that problem.

So to sum it up:
1: unzip, script needs to change drive too, not just directory ("cd /d
some-path" or similar)
2: mysl version needs fixing
3: qt3 build needs fixing so it doesn’t run 1000s of compilations in
4: runtimeprefix command doesn’t exist and don’t know what its supposed to
5: mythplugins linking error, related to 4?

More information about the mythtv-dev mailing list