[mythtv] Problems with Win32 port script

Jonathan Larson jtlarson at u.washington.edu
Thu Aug 14 15:50:56 UTC 2008

I thought I'd give the Win32 port another try  and so I removed all the previously installed components (Msys, Mingw, Mysql, all source directories) from a previous un-successful attempt and downloaded the Mythinstaller.bat. I ran into a few problems which I worked around, but the last one is a compile error that I'm not sure how to fix.

1.       When I run MythInstaller.bat, it downloads and executes win32packager.pl, but immediately after pressing [Enter] at the config summary the script appears to drop back to a command prompt-I say 'appears' because no matter what command I give next (even just pressing enter again) will execute win32-packager.pl. Just slightly confusing...

2.       MySql essentials is now up to version 5.0.67 (vs. 5.0.45 in the script), so the initial download attempt failed. I edited win32-packager.pl to the new version and re-ran win32-packager.pl

3.       The script stalls permanently at the "qt-win-opensource-src-4.4.0.zip" download-it claims that it's downloading, but I see no evidence of it in the network traffic and letting it sit for 1 hour produced no results. I copied the download path into my browser and downloaded the file manually in 10 minutes, so I don't think it a problem with my computer in general-the script just doesn't seem to be initializing the download process for some reason. I cancelled the script, copied qt-win-opensource-src-4.4.0.zip to the source dir and restarted win32-packager.pl to continue.

4.       The compile process errored out with the messages below. I searched the list history and found http://www.gossamer-threads.com/lists/mythtv/dev/344111 and http://mythtv.org/pipermail/mythtv-dev/2008-July/062610.html

Buzz's suggestion to

1) locate where pwd.exe is.
2) export PATH=$PATH:/blah/folderwithpwd/

The problem is, I'm not sure where/when to do this, so any advice would be appreciated.

        QT version: 4
        DLLs will be labeled as: 0.22
        Building with 2 processors
        SVN location is: trunk
        SVN revision is: 18010


g++ -c -march=k8 -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non
-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -frtti -fexceptions -mth
I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include/QtCore' -I'../../../.
./MSys/1.0/qt-win-opensource-src-4.4.0/include/QtCore' -I'../../../../MSys/1.0/q
t-win-opensource-src-4.4.0/include/QtNetwork' -I'../../../../MSys/1.0/qt-win-ope
nsource-src-4.4.0/include/QtNetwork' -I'../../../../MSys/1.0/qt-win-opensource-s
rc-4.4.0/include/QtGui' -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/incl
ude/QtGui' -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include/QtOpenGL'
 -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include/QtOpenGL' -I'../../
../../MSys/1.0/qt-win-opensource-src-4.4.0/include/QtXml' -I'../../../../MSys/1.
0/qt-win-opensource-src-4.4.0/include/QtXml' -I'../../../../MSys/1.0/qt-win-open
source-src-4.4.0/include/QtSql' -I'../../../../MSys/1.0/qt-win-opensource-src-4.
4.0/include/QtSql' -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include/Q
t3Support' -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include/Qt3Suppor
t' -I'../../../../MSys/1.0/qt-win-opensource-src-4.4.0/include' -I'/C/mythtv/bui
ld//include' -I'../libmythsamplerate' -I'../libmythsoundtouch' -I'../libmythfree
surround' -I'../libavcodec' -I'../libavutil' -I'../libmythdb' -I'../..' -I'..' -
I'.' -I'../libmythupnp' -I'../libmythui' -I'c:/MSys/1.0/qt-win-opensource-src-4.
4.0/include/ActiveQt' -I'.' -I'.' -I'../../../../MSys/1.0/qt-win-opensource-src-
4.4.0/mkspecs/win32-g++' -o uilistbtntype.o uilistbtntype.cpp
schemawizard.cpp: In member function `MythSchemaUpgrade SchemaUpgradeWizard::Pro
mptForUpgrade(const char*, bool, bool, int, int, int)':
schemawizard.cpp:242: error: `isatty' was not declared in this scope
make[2]: *** [schemawizard.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/C/mythtv/mythtv/libs/libmyth'
make[1]: *** [sub-libmyth-make_default-ordered] Error 2
make[1]: Leaving directory `/C/mythtv/mythtv/libs'
make: *** [sub-libs-make_default-ordered] Error 2
EFFECT FAILED (newer -> shell): mtime of file (C:/mythtv/mythtv/libs/libmyth/lib
myth-0.22.dll) should be greater than file (C:/mythtv/mythtv/last_build.txt).
[0]  [1218724582]

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080814/bd76a749/attachment.htm 

More information about the mythtv-dev mailing list