[mythtv] length mismatch in programinfo on QT4

Kevin Kuphal kkuphal at gmail.com
Thu Apr 10 13:39:41 UTC 2008

On Thu, Apr 10, 2008 at 2:44 AM, Gregorio Gervasio, Jr. <gtgj at pacbell.net>

> >>>>> Kevin Kuphal writes:
> k> Hi.  I just took the plunge to QT4 on my two FC6 systems.  The backend
> was a
> k> clean compile of new sources (16983) and started up fine.  My frontend
> is a
> k> brand new built FC6 frontend from the same revision but when I try to
> view
> k> Watch Recordings I get an error of a mismatch in the length of
> programinfo
> k> even though that struct hasn't changed in *forever*.  Any ideas why
> this
> k> would be?  A verbose log from the system only shows the command to get
> the
> k> PLAY list right before the error.  I checked by includes both in and
> out of
> k> my source tree and both have 46 as the length.
>        I ran into this problem, too.  In my case, it seemed to be
> caused by some recordings with bad bookmarks.  After I did this in
> mysql:
> update recorded set bookmark=0 where bookmark=127;
> ... the problem went away.  I haven't tried to debug it further than
> that.

Well, I reverted to my pre-QT4 upgrade DB backup, recompiled after putting
back the QT3 rpms and the machine works fine again.  Maybe it's something
with the QT4 MySQL driver on FC6.  I may try this again but with some
virtual machines.  Did any other developers move to QT4 on FC6?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080410/9ee55784/attachment.htm 

More information about the mythtv-dev mailing list