[mythtv] having problems with upnp on a netgear mp101

Daniel Burr dburr at virginbroadband.com.au
Sun Oct 28 23:44:08 UTC 2007

On Sun, 2007-10-28 at 22:08 +0000, Simon Kenyon wrote:
> my mp101 (which used to work) is now saying unsupported format when i
> try to play any music. it used to work.
> so i turned on logging for upnp and see almost not messages.
> i see some initialisation stuff at the start; but nothing when the mp101
> connects to my backend.
> my first questions is: is this expected?
> my second question is: does anybody have any idea what has changed?

Sounds like you may be having the same problem as I am:

The advantage that you have is that yours was actually known to work at
some stage in the past.  I have unsuccessfully tried SVN revisions
14251, 14666 and 14722 although Denon 4306 support was reported to work
in changeset 14268.  Do you know what the most recent revision that has
worked with your MP101 is?  Hopefully that can provide us with a
starting point to track down the change which introduced the breakage.

I myself have had a bit of a fiddle with libs/libmythupnp/upnpdevice.cpp
to see if enabling the MediaReceiverRegistrar would help (it didn't).
The only other functional changes that I can see from changeset 14250
* the code that writes out a <deviceList> for embedded devices was
commented out
* some of the protocol strings changed from "*" to "DLNA.ORG...."

Are you able to try reversing the above changes one at a time to see if
they help?


More information about the mythtv-dev mailing list