[mythtv] Mythweb video problem

Tom Lichti tom at redpepperracing.com
Fri Jun 1 19:11:52 UTC 2007

Michael T. Dean wrote:
> On 06/01/2007 01:34 PM, Tom Lichti wrote:
>> I'm pretty sure I screwed this up, but I can't seem to figure out how, 
>> or how to fix it. I wanted to clean up my mythvideo table, since there 
>> were many entries that were obsolete, so instead of being patient and 
>> using a frontend I just emptied the videometadata table. Now after doing 
>> a video scan on a frontend (I couldn't use mythweb because the mythvideo 
>> icon didn't even appear) I have my videos back but I can't do imdb 
>> lookups on them anymore. This was working previously. When I click on 
>> the IMDB button, I get:
>> Fatal Error, IMDB was not set in settings table, please set it via the 
>> settings tab.
>> In the settings tab for the server I have:
>> MovieDataCommandLine   /usr/local/bin/imdb.pl -D
>> MovieListCommandLine   /usr/local/bin/imdb.pl -M tv=no;video=no
>> MovieDataCommandLine   /usr/local/bin/imdb.pl -P
>> VideoArtworkDir   /myth/movies/.posters
>> VideoStartupDir   /myth/movies
>> Am I missing something?
> MoviePosterCommandLine
> should be something like "imdb.pl -P", but really, you're probably
> better off using "/usr/local/share/mythtv/mythvideo/scripts/imdb.pl"
> instead of "/usr/local/bin/imdb.pl" so you're always using the most
> up-to-date version.
You got my hopes up, but then I realized that my post above is wrong, I 
have MovieDataCommandLine twice, when I meant to put:

MoviePosterCommandLine /usr/local/bin/imdb.pl -P
> Oh, but /usr/local/bin/imdb.pl is a symlink to
> /usr/local/share/mythtv/mythvideo/scripts/imdb.pl...  Well, be careful
> with patch, then.  If you were to forget that the command you always use
> to call it is hitting a symlink, you saw an unapplied patch that fixes
> poster-grabbing, and you apply it to "/usr/local/bin/imdb.pl," it's no
> longer a symlink; and now, "It works from the command-line, but
> MythVideo/MythWeb is broken." ;)
It's actually a symlink to /usr/local/src/scripts/imdb.pl which is my 
SVN checkout of said file, which gets updated by my SVN update script so 
I don't have to worry about it. And yes, it does work from the 
command-line, but not within MythVideo/Mythweb. Any other ideas? :)


More information about the mythtv-dev mailing list