[mythtv] Problem tuning to channel after 6pm with 0.20

Simon Dyson sdyson at themaelstrom.co.uk
Tue Oct 3 08:12:37 UTC 2006

Stuart Auchterlonie wrote:
> Okay this is really odd. I've checked my recordings and I have
> numerous recordings made between 6pm and 6am from ch4, all of
> which work fine.
> There is nothing to my knowledge that Channel 4 have changed
> in their broadcast paramaters. If there was you wouldn't be
> able to receive it at *any* time, not just at a particular
> time of day. So that leads me to believe it's something local
> to your setup.
> Do you have a Set Top Box to verify ch4 is received correctly
> in your house at this time?
> For those recordings you have that won't play could you get
> a copy of the frontend output running with
> --verbose channel,record,playback
> Also, have you tried rescanning the channels? If not, take
> a database backup and rescan your channels.
> Stuart

Thanks for the advice. I don't have a set top box so I have no other way
to verify that I can receive Channel 4.

I did rescan the channels when the problem first occurred after the
upgrade but it didn't seem to help. I will give it another go tonight if 
I get the chance.

I ran with the logging level you suggested and attached are two log
files, one is the result of trying to watch a Ch4 recording, the other
is the result of watching another recording that works fine. I made the
2 log files so I could compare them myself for differences (useful since
both logs show some of the same errors so these are most likely red
herrings). One error that caught my eye that only occurred for the ch4
recording was:

3: start_time: 6680.409 duration: -9223372036854.775

'3' seems to refer to the subtitles stream and apparently has a very
large negative duration. AFAIK 0.19 did not support subtitles so this
may be a clue as to why these recordings have stopped working since the
upgrade. But let me know if I'm just barking up the wrong tree here.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: errorlog.txt
Url: http://mythtv.org/pipermail/mythtv-dev/attachments/20061003/87328ffd/attachment.txt 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: noerrorlog.txt
Url: http://mythtv.org/pipermail/mythtv-dev/attachments/20061003/87328ffd/attachment-0001.txt 

More information about the mythtv-dev mailing list