[mythtv] SVN help

jam at tigger.ws jam at tigger.ws
Thu May 25 11:14:52 UTC 2006

On Thursday 25 May 2006 17:15, mythtv-dev-request at mythtv.org wrote:
> > [tigger] /home/jam/myth [113]% svn co
> > http://svn.mythtv.org/svn/trunk/mythtv svn: REPORT request failed on
> > '/svn/!svn/vcc/default'
> > svn: REPORT of '/svn/!svn/vcc/default': 400 Bad Request
> > (http://svn.mythtv.org)
> That's an interaction between svn & squid.
> See the svn FAQ for the solution.

Thanks for that, I'm not running squid! (but my isp probably is)
Please help a tiny bit more ...
The list appended gave me no hints
Thanks James


    * My repository seems to get stuck all the time, giving me errors about 
needing recovery (DB_RUNRECOVERY). What could be the cause?
    * Every time I try to access my repository, the process just hangs. Is my 
repository corrupt?
    * My repository keeps giving errors saying "Cannot allocate memory". What 
should I do?
    * Every time I try to run a svn command, it says my working copy is 
locked. Is my working copy corrupt?
    * I'm trying to commit, but Subversion says my working copy is out of 
    * I just built the distribution binary, and when I try to check out 
Subversion, I get an error about an "Unrecognized URL scheme." What's up with 
    * I'm getting errors finding or opening a repository, but I know my 
repository URL is correct. What's wrong?
    * When I run `configure', I get errors subs-1.sed line 38: Unterminated 
`s' command. What's wrong?
    * I'm getting errors trying to build Subversion 1.2 on Windows — 
mod_dav_svn won't build.
    * I'm having trouble building Subversion under Windows with MSVC++ 6.0. 
What should I do?
    * How can I specify a Windows drive letter in a file: URL?
    * I'm having trouble doing write operations to a Subversion repository 
over a network.
    * VS.NET/ASP.NET seems to have a problem with the ".svn" directory name. 
What should I do?
    * Under Windows XP, the Subversion server sometimes seems to send out 
corrupted data. Can this really be happening?
    * What is the best method of doing a network trace of the conversation 
between a Subversion client and server?
    * Why does the svn revert require an explicit target? Why is it not 
recursive by default? These behaviors differ from almost all the other 
    * When I start Apache, mod_dav_svn complains about a "bad database 
version", that it found db-3.X, rather than db-4.X.
    * I'm getting "Function not implemented" errors on Red Hat 9, and nothing 
works. How do I fix this?
    * Why does SVN log say "(no author)" for files committed or imported via 
Apache (ra_dav)?
    * I'm getting occasional "Access Denied" errors on Windows. They seem to 
happen at random. Why?
    * On FreeBSD, certain operations (especially svnadmin create) sometimes 
hang. Why?
    * I can see my repository in a web browser, but 'svn checkout' gives me an 
error about "301 Moved Permanently". What's wrong?
    * I'm trying to look at an old version of my file, but svn says something 
about "path not found". What's going on?
    * Why doesn't HTTP Digest auth work?
    * Compiling with xlc on AIX, I get compilation errors. What's wrong?
    * I checked out a directory non-recursively (with -N), and now I want to 
make certain subdirectories "appear". But svn up subdir doesn't work.
    * I am trying to use mod_dav_svn with Apache on Win32 and I'm getting an 
error saying that the module cannot be found, yet the mod_dav_svn.so file is 
right there in \Apache\modules.
    * Why aren't my repository hooks working?
    * Why does my --diff-cmd complain about '-u'? I tried to override it with 
--extensions, but it's not working.
    * Ahhh! I just discovered that my Subversion client is caching passwords 
in plain-text on disk! AHHH!
    * I'm getting the error "svn: bdb: call implies an access method which is 
inconsistent with previous calls". How do I fix this?
    * I can't hotbackup my repository, svnadmin fails on files larger than 
    * I cannot see the log entry for the file I just committed. Why?
    * After upgrading to Berkeley DB 4.3 or later, I'm seeing repository 
    * Why do I get occasional, seemingly inconsistent errors checking out over 
http:// from a repository running on MacOS X 10.4 (Tiger)?
    * I can't build Subversion from working copy source on Debian GNU/Linux; I 
get errors at the final link stage. What's wrong?

More information about the mythtv-dev mailing list