[mythtv] HD3000: Could not get card info for card #0!

David Cain sblkMythDev at jimmiedave.com
Sat May 13 04:23:27 UTC 2006

Sorry for having to ask this on the Dev list, but I've tried 
MythTV-User twice, searched the archives and the web and don't have any 
answers. Have been stalled at this point for about a month and thought 
you folks might recognize these symptoms.

I've set up MythTV systems twice before (.17 Sarge, .17, .18 Ubuntu, 
PVR-350, been using it happily for a year).

I'm now trying to set up my 2 HD3000 cards in a brand-new backend.

Kernel 2.6.16-1 on Debian Sarge AMD64 SMP, headless backend server.

Using MythTV 0.19 stable debs from Marillat's repository.

azap (from linuxtv.org's dvb-tools (CVS)) works, shows the cards 
locking signal on the DVB side. Have gotten some crummy analog NTSC 
video (but not audio) out of the analog tuner section.

I've checked and the mythtv user (video group) should have permissions 
on the /dev/dvb folder and its contents. (and I've tried as root too, 
so that ought to give me permission...)

The firmware can be loaded: azap, along with a tail -f on syslog prove 

But when I go to mythtv-setup (which I'm runing on a remote X display 
on my PowerBook - don't have X on the server) and try to set up the 
cards as DVB DTV capture cards, I get:

	Frontend ID: Could not get card info for card #0! Subtype: Invalid 

Then once I change the DVB card number to something else (card 1, for 
example) I get:

	Frontend ID: Could not get card info for card #1! Subtype: Success

If I change back to card 0, I then see:

	Frontend ID: Could not get card info for card #0! Subtype: Success

In no case can I configure a working card. If I switch to card numbers 
that don't represent a card in the machine, the machine correctly 
detects that:

	Frontend ID: Could not open card #2: Subtype: No such file or directory


I note that I couldn't compile some of the dvb-tools in an earlier 
attempt - they too said something about frontend (and 'FE_ATSC' - 
"FrontEnd"?) Anyone got any ideas here?

Is the issue that I've only installed mythtv-backend and 
mythtv-database on this machine?

I've been stuck here for nearly a month. Nobody seems to have solved 
this, or at least no one has reported on the solution anyplace I can 
find it.

Desperate for ideas here...any help appreciated!


More information about the mythtv-dev mailing list