[mythtv] MythTV on Mac OS X for Intel

Geoffrey Kruse gkruse at gmail.com
Fri Jan 27 02:20:41 UTC 2006


> Hello.
>
> As the owner of a shiny new Intel Core Duo powered iMac and a
> faithful MythTV user, I decided I wanted to try to build an Intel
> version of mythfrontend for OS X.  Using a slightly modified version
> of mythtv/contrib/osx-packager.pl (just to get newer versions of
> MySQL and qt-mac, and to disable the DVD playback features, as I
> don't need them and they weren't compiling anyway), I was able to
> build all of the prerequesites, and got the build of MythTV to start.
>
> It ran into a problem, however.  It looks like it happens the first
> time it tries to run the linker.  Here is the last command it ran,
> followed by the error messages it spewed...
>
> <Snip>

> ld: Undefined symbols:
> magicF2W
> wm0101
> wm1010
> wm1100
> /usr/bin/libtool: internal link edit command failed
> make[2]: *** [libmythavcodec-0.18.2.0.18.2.dylib] Error 1
> make[1]: *** [sub-libavcodec] Error 2
> make: *** [sub-libs] Error 2
> [osx-pkg] Failed system call: " /usr/bin/make " with error code 2
> Died at osx-packager.pl line 760.
>
> I searched the archives, but didn't find anything relevant.  Any help
> would be appreciated.
>
>

These undefined symbols seem to be related to ffmpeg.  A place to  
start would by to post the output of configure so we can tell how it  
is detecting your cpu.  Also, it looks like you are building 18.2  
instead of head?   If this is the case, you might try building head  
instead.

Geoff
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2361 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-dev/attachments/20060126/0e9a7d56/smime.bin


More information about the mythtv-dev mailing list